[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

unable to resize ext3 partition - thinks its ext2...

From: Nicholas White
Subject: unable to resize ext3 partition - thinks its ext2...
Date: Sat, 06 Mar 2004 14:15:33 +0000

I have parted 1.6.6 running on redhat 9. I would like to resize this ext3 partition, but when I tried it gave the output:

(parted) resize 2 38162.219 48162.219
Error: Filesystem was not cleanly unmounted! You should e2fsck. Modifying an
unclean filesystem could cause severe corruption.
Ignore/Cancel? i
No Implementation: This ext2 filesystem has a rather strange layout!  Parted
can't resize this (yet).

the 'print' command gives:

(parted) print
Disk geometry for /dev/hda: 0.000-76319.085 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031  38162.219  primary   ntfs        boot
2      38162.219  76316.594  primary   ext3

Is this something to do with the filesystem not being unmounted correctly? I tried to use e2fsck, but it strongly warned against using it on a mounted filesystem (i.e. my redhat 9 partition). Can you tell me how to get it working? Thanks,

Nicholas White

Tired of 56k? Get a FREE BT Broadband connection http://www.msn.co.uk/specials/btbroadband

reply via email to

[Prev in Thread] Current Thread [Next in Thread]