[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error from parted 1.6.9 when resizing ext3 partition

From: Amit D. Chaudhary
Subject: Error from parted 1.6.9 when resizing ext3 partition
Date: Wed, 21 Apr 2004 20:48:20 -0700
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113


I search the archives but could not find any answer to this. I have a root filesystem with ext3, kernel 2.4.25.

I wanted to resize it down by a couple of GBs, tried the default boot disk (parted 1.6.6) and since that did not work, tried a statically build parted 1.6.9 with e2fsprogs 1.35.

I run into the following error message.

No Implementation: This ext2 filesystem has a rather strange layout! Parted
can't resize this (yet).

address@hidden /dev/hda print
Warning: Unable to determine if partitions are mounted via /proc/mounts or /etc/mtab. Make sure you don't
attempt to resize or modify mounted file systems.  (Even read-only mounted)
Ignore/Cancel? I
Disk geometry for /dev/hda: 0.000-76293.945 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031     39.221  primary   fat16
2         39.221  20042.028  primary   ntfs
3      20042.029  55043.020  extended              lba
5      20042.060  55043.020  logical   fat32
4      55043.020  74041.765  primary   ext3        boot
Information: Don't forget to update /etc/fstab, if necessary.

The above output is not from the real run, but after booting into the main linux as the disk was ram based.

Comments, suggestions?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]