[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bad superblock and totaly not working fs after resize

From: Rumen Krasstev
Subject: Bad superblock and totaly not working fs after resize
Date: Tue, 01 Jun 2004 18:56:11 +0300

Hello Parted team,
As other guys that wrote here I made very stupid things and I'm sorry
sentence doesn't help to fix such terrible mistakes. I have very
important data (Murphy low, you know) in this crashed partition that
I'll describe below, thats why I'm so desperate :(
So what happens:
1. I installed SuSe 9.1 and during the installation there was front-end
for parted (version 1.6.6. said rpm -ql parted). I used this tool to
shrink (a rash action) my most important partition (25GB EXT3) to make
space for the SuSe installation. I knew that if the beginning of the
partition is not moved there is no danger (almost). So I shrink only the
end (without moving the partition) or the front-end said like that. The
installation was ok, but after reboot, none of mine Debian, Fedora or
SuSe had success for mounting this partition, so I checked what's going
2. Mount command returns me "you must specify the filesystem type", so
after few combinations of mount I discovered that I have a problem and
start fsck...
3. fsck /dev/hda10 returns me "fsck.ext3: Bad magic number in
super-block while trying to open /dev/hda10"... and of course I tried
e2fsck -b 8193 /dev/hda10, again with the same result, so I decided to
make a simple for cycle with fsck -n -b $I /dev/hda10 where $I was from
0 to 40000.. same result.. After long thinking and going angry to myself
I got an idea and tried..
4. mk2fs -n /dev/hda10 will show me the right superblock numbers! Yeah,
but no, it shows me and I tried these numbers with fsck - again without
result - may be because the partition is already resized (and probably
moved his beginning by this damned front-end)..
So I continued trying to recover my data (at least the sources for
Debian, SuSe etc., thanks of god I commit them before few months into
remote cvs) whole week but again - without any result..

Here is what fdisk /dev/hda tells me:

Disk /dev/hda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         523     4195768+   7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/hda2            1568        7296    46017720    f  W95 Ext'd (LBA)
/dev/hda3   *         523        1045     4195800   83  Linux
/dev/hda4            1045        1568     4195800   83  Linux
/dev/hda5            1568        2396     6652768+   b  W95 FAT32
/dev/hda6            2396        2462      529168+  82  Linux swap
/dev/hda7            2462        2592     1050808+  83  Linux
/dev/hda8            2593        3115     4195768+  83  Linux
/dev/hda9            3115        3637     4195768+  83  Linux
/dev/hda10           3638        6738    24908751   83  Linux
/dev/hda11           6739        7296     4482103+  83  Linux

The damaged partition is /dev/hda10, the new one created after resizing
is /dev/hda11..

I apologise for the long letter, but I really finished ideas and hopes
for recovering the partition.
Please guys tell me that there is a solution, please :-/

Rumen Krasstev

Rumen Krasstev - Object Builder Software Bulgaria
Sofia, 113 Tzarigradsko Shose, phone: +359 2 974 33 16
web: http://www.obs.bg, email: address@hidden, icq: 35447386

reply via email to

[Prev in Thread] Current Thread [Next in Thread]