[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Resize boot partition on RHEL AS 3.0

From: Rakesh Nagarajan
Subject: RE: Resize boot partition on RHEL AS 3.0
Date: Thu, 03 Jun 2004 20:16:58 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

I am trying to resize the boot partition as I have run out of space on it. The next contiguous partition was the swap and so I removed this partition and made a new swap on another drive. Now I had the following:

1   0.031         101.975       primary    ext3   boot
2   2094.412   76293.261   primary    ext3

I changed the ext3 for Minor 1 to ext2 using tune2fs using my Disc 1 and booting into rescue mode. When I print in parted, it sees Minor 1 as ext2 now. I tried resizing Minor 1 by:

resize 1 0.031 2094.411

and it gives the error: No implementation! This ext2 filesystem ha a rather strange layout! Parted can't resize this (yet).

How can I resize this boot partition? I have tried a boot disk from the parted website also with no success. I can create another partition in that empty space bu I cannot resize to fill that empty space.

Thanks in advance for any help and advice I can get on this issue.


Rakesh Nagarajan, M.D., Ph.D.
Instructor, Department of Pathology and Immunology
Division of Laboratory Medicine
660 S. Euclid Avenue, Campus Box 8118
Saint Louis, MO 63110
LAB:  Clinical Sciences Research Building, Room 8856
FAX:  314-362-3016

reply via email to

[Prev in Thread] Current Thread [Next in Thread]