bug-parted
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Parted 1.6.22


From: Mathieu Bruneau
Subject: Re: Parted 1.6.22
Date: Sun, 20 Mar 2005 00:13:58 -0500
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

Andrew Clausen wrote:
Hi all,

I have just uploaded Parted 1.6.22.  Summary of changes:

* hfs and hfs+ shrinking support merged.  (thanks to Guillaume Knispel)
This includes some backward compatible API changes related to cache
flushing.

* gcc4 fixes (thanks to Chris Lumens)

* minor UI and documentation changes/fixes.

The ChangeLog follows.

Cheers,
Andrew


2005-03-14  Chris Lumens  <address@hidden>
* libparted/fs_fat/fat.h:  Change name to a char array in _FatDirEntry.
* libparted/fs_fat/traverse.c (fat_dir_entry_is_active): One last unsigned
  char vs. char compiler warning fix.
* libparted/device.c:  Functions named things like read, write, and check
  can be implemented as macros which will get expanded here and cause
  problems.  Surround the names with parentheses to prevent macro expansion.
* libparted/linux.c (_mount_table_search):  Ignore sccanf result.

2005-03-11  Guillaume Knispel <address@hidden>
* libparted/fs_hfs/hfs.c, libparted/fs_hfs/reloc.c,
  libparted/fs_hfs/reloc_plus.c: Make use of ped_geometry_sync_fast in hfs
  and hfs+ code.

2005-03-08  Chris Lumens  <address@hidden>
* libparted/disk_amiga.c, libparted/disk_gpt.c, libparted/disk_pc98.c,
  libparted/disk_sun.c, libparted/linux.c, libparted/fs_hfs/reloc.c:  Fix up
  unsigned char vs. char compiler warnings.

2005-03-07  Chris Lumens  <address@hidden>
* libparted/disk_mac.c: support LVM on PPC by setting the proper flags on the
  partition (patch from Paul Nasrat <address@hidden>).

2005-03-06  Andrew Clausen <address@hidden>
* libparted/disk_sun.c: many changes, including:
        - replaced hw_geom with bios_geom.
        - disk_specific->length is now set to cylinder_size * label->ncyl.
        - label->acyl is now set to 0 by default.

2005-03-05  Andrew Clausen <address@hidden>
* doc/parted.8: changed "mips" to "dvh" to be consistent with the Parted
  user interface.
* doc/parted.texi: added http:// and ftp:// onto some URLs.

2005-03-04  Chris Lumens <address@hidden>
* libparted/fs_fat/context.c: fix casting typo.
* include/parted/constraint.h, libparted/constraint.c: remove
  ped_constraint_none that wasn't being referenced anywhere.

2005-03-04  Andrew Clausen <address@hidden>
* libparted/fs_fat/count.c (flag_traverse_fat): in the assignment to
  cluster_info [clst].units_used, store 0, rather than 64.  The code
  has the same semantics, but no gcc4 compiler warning.  (0 == 64 when
  you use 6-bit integers; 0 is interpreted as 64 in all relevant code)
  (problem reported by Chris Lumens <address@hidden>)

2005-02-19  Guillaume Knispel <address@hidden>
* libparted/fs_hfs/hfs.c (hfs_resize): do nothing when nothing to do.
* libparted/fs_hfs/hfs.c (hfsplus_resize): do nothing when nothing to do.
* libparted/fs_hfs/hfs.c (hfsplus_open): leak in the error handling code
  corrected.

2005-02-17  Guillaume Knispel <address@hidden>
* include/parted/device.h (_PedDeviceArchOps): field sync_fast added.
* include/parted/device.h (ped_device_sync_fast): added.
* include/parted/geom.h (ped_geometry_sync_fast): added.
* libparted/device.c (ped_device_sync_fast): added.
* libparted/geom.c (ped_geometry_sync_fast): added.
* libparted/gnu.c (gnu_dev_ops): sync_fast pointing to gnu_sync added.
* libparted/linux.c (linux_sync_fast): added.
* libparted/linux.c (linux_dev_ops): sync_fast pointing to linux_sync_fast
  added.
* doc/API : new ped_device_sync_fast and ped_geometry_sync_fast API
  documented.

2005-02-14  Chris Lumens <address@hidden>
* parted/parted.c : on the help for the mkfs, mkpart, and resize commands,
  only list filesystem types that are supported

2005-02-02  Guillaume Knispel <address@hidden>
* integrated HFS Patch 16 :
* libparted/fs_hfs/hfs.c
* libparted/fs_hfs/hfs.h
* libparted/fs_hfs/probe.c
* libparted/fs_hfs/probe.h
* libparted/fs_hfs/cache.c
* libparted/fs_hfs/cache.h
* libparted/fs_hfs/advfs.c
* libparted/fs_hfs/advfs.h
* libparted/fs_hfs/file.c
* libparted/fs_hfs/file.h
* libparted/fs_hfs/reloc.c
* libparted/fs_hfs/reloc.h
* libparted/fs_hfs/advfs_plus.c
* libparted/fs_hfs/advfs_plus.h
* libparted/fs_hfs/file_plus.c
* libparted/fs_hfs/file_plus.h
* libparted/fs_hfs/reloc_plus.c
* libparted/fs_hfs/reloc_plus.h
* libparted/Makefile.am : modified according new source files listed above
* libparted/disk_mac.c (mac_partition_set_system): tag partition with type
  "Apple_HFS" if the filesystem is "hfs+" in addition to "hfs"
* debug/test/test_fs_hfs : new non-regression tests for hfs
* debug/test/test_fs_hfsplus : new non-regression tests for hfs+
* debug/test/test (ped_test_get_val): allow bash evaluation of $post_command
* doc/parted.texi (Supported File Systems): added resize operation for hfs
  and hfs+, and a note stating they can only be made smaller.
* doc/parted.texi (Command explanation Resize): talk about hfs.



_______________________________________________
Bug-parted mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/bug-parted


I just commited the update of the website! It should be updated automagically.

--
Mathieu Bruneau
aka ROunofF

===
GPG keys available @ http://rounoff.darktech.org


--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.308 / Virus Database: 266.7.3 - Release Date: 2005-03-15





reply via email to

[Prev in Thread] Current Thread [Next in Thread]