[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [version 1.6.21] Assertion (dis k != NULL) at ../../libparted/disk.c

From: eliehd
Subject: Re: [version 1.6.21] Assertion (dis k != NULL) at ../../libparted/disk.c:1037 in function ped_disk_next_partition() failed
Date: Thu, 24 Mar 2005 21:08:10 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050324 Debian/1.7.6-1


As you suggested, I tested parted instead of qtparted, and I get the following result:

Using /dev/hda
(parted) print
Error: Unable to satisfy all constraints on the partition.
(parted) check
Error: Unable to satisfy all constraints on the partition.

I tried your second suggestion, and deleted partition /dev/hda1 with fdisk, that solved my issue with parted or qtparted:
I can now use either tool without any error!
It seems that parted had a problem with my swap partition (hda1) being in the middle of my extended partition (hda2) instead of being at the start of the disk as its number should have indicated... Maybe it's related to the fact that the first cylinders of my disk are not formatted (reserved free space to test distros).

Thanks Andrew!

Andrew wrote:
Hi eliehd,

On Wed, Mar 23, 2005 at 09:38:40PM +0100, eliehd wrote:
> When trying to access the partition list of this drive with qtparted, I
> get the following error in a message box:

Is it possible to test out Parted (as opposed to qtparted)?  This
will help determine if the bug is located in Parted or qtparted.

> However, when i run fdisk -l, I can read the partition table:
> Disk /dev/hda: 123.5 GB, 123522416640 bytes
> 255 heads, 63 sectors/track, 15017 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> ~   Device Boot      Start         End      Blocks   Id  System
> /dev/hda1 * 9306 9396 724248 82 Linux swap / Solaris
> /dev/hda2            1147       15018   111414744    5  Extended
> /dev/hda5            1147        9306    65535592+  83  Linux
> /dev/hda6            9396       15018    45154840+  83  Linux
> Partition table entries are not in disk order

Partition 1 overlaps with partition 2.  I recommend you use fdisk to:
(1) delete partition 1.
(2) create a logical partition 7, in the same location.
(3) update /etc/fstab to use partition 7 for swap rather than partition

Note: you should check if partition 1 is involved in the boot process.
(It probably isn't, but...)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]