[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trying to get a partition shared between WinXP and FC3

From: Leslie Katz
Subject: Trying to get a partition shared between WinXP and FC3
Date: Fri, 19 Aug 2005 16:06:18 +1000

Recently, I posted to the list some questions on the above topic, among which was whether Windows XP Professional (on hda) would recognise an existing partition on hdb if I were able to change the filesystem type of that partition from ext3 to FAT32 using parted.

Benno Schulenberg kindly replied to my questions to the list, with a copy of his reply to me directly.

I'm not sure I've seen anything from the list yet with either my or Benno's posts in it, but, in any event, as to my question mentioned above, he said that he didn't know the answer, but that I should give it a go and report the result to the list.

That's what I'm doing in this post.

I was able to change the filesystem type of the relevant partition in the way mentioned above. After remounting the partition, I opened gedit and typed "test". I saved that document, with the name "test", to "/shared", the directory representing the partition.

I then restarted the computer, choosing Windows as the OS I wanted. I next went to "Computer Management", "Disk Management". Hdb was there, called "Disk 1", and the FAT32 partition on it had been given a letter, "G". I closed "Computer Management".

I then opened Word and then used "Open file" to navigate to drive G:. I tried to open "test", which was visible. It worked. I then added the word "test" to the file a second time and saved the file as "test.txt".

I then restarted the computer, choosing Linux as the OS I wanted. I next started Writer and tried to open "test.txt", which was visible. It worked, but "read-only". I checked the file's permissions and saw that ordinary users weren't permitted to write to the file.

At that stage, I stopped the experiment.

It seems as though the sharing works when set up from the Linux side only, with various problems that I suppose can be worked out, depending on the types of files dropped into the shared partition.

The only other comment I'd make is that, as a beginner in Linux, I would have appreciated more information in the parted info page about the process of changing the partition's filesystem type. I unmounted the partition before changing its filesystem type, something I didn't notice stated in the info page. However, I didn't remount the partition before rebooting my computer, thinking I could mount it manually after the re-boot to try it out. That was seriously wrong, because I hadn't edited my /etc/fstab file before rebooting. I would have preferred not to have to figure out myself how to get things going again, but to have that information in advance from the info page.

My thanks to Benno for his help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]