[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: assertion PED_LE64_TO_CPU (gpt->AlternateLBA) <= disk->dev->length f

From: Jim Meyering
Subject: Re: assertion PED_LE64_TO_CPU (gpt->AlternateLBA) <= disk->dev->length failed
Date: Tue, 26 Aug 2008 11:14:32 +0200

Bjorn Helgaas <address@hidden> wrote:

> [I tried to submit this via Trac, but it said "500 Internal Server Error
> (Submission rejected as potential spam)"].
> I also tried to debug this with gdb, but the parted I built complains
> like this:

Sometimes it's easier to debug if you configure like this:

    ./configure --enable-debug --disable-shared CFLAGS=-g

>   $ /usr/local/sbin/parted ../rhel5.2-image
>   /usr/local/sbin/parted: error while loading shared libraries: 
> libparted-1.8.so.8: cannot open shared object file: No such file or directory

> ... I used dd to copy the first 5GB of /dev/sda to the file rhel5.2-image.
> The GPT scheme keeps a secondary copy of the partition table at the
> end of the disk.  My rhel5.2-image file is obviously missing that,
> since it only contains the first 5GB of the disk image.  That might
> explain this assertion failure.

Yes, that is probably the root of the problem.
The assertion is Parted's way of warning you that your
disk/partition table is corrupted in a surprising/unusual way.
Can you suggest a better way to handle this sort of failure?

> But I hope parted can handle this situation more gracefully.

> ...
> Assertion (last_usable <= disk->dev->length) at gpt.c:689 in function
> _parse_header() failed.
> Ignore/Cancel? i
> Error: Can't have a partition outside the disk!
> Error: Can't have a partition outside the disk!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]