[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-patch] [patch-2.7.6] make check FAIL on Solaris11 x86/x64

From: Dennis Clarke
Subject: Re: [bug-patch] [patch-2.7.6] make check FAIL on Solaris11 x86/x64
Date: Tue, 6 Feb 2018 18:45:52 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0

On 06/02/18 05:39 PM, Kiyoshi KANAZAWA wrote:

% ./configure CC=gcc
% make
% make check

There are 3 FAILs in "make check".
FAIL: crlf-handling
FAIL: git-cleanup
FAIL: merge

2nd one might be because I do not have git.

Tried on Solaris 11.3 x86/x64, with gcc-7.3.0.

Hardly the same thing but everything works perfect on Solaris 10 SPARC with the Oracle Studio compilers :

PASS: asymmetric-hunks
PASS: backup-prefix-suffix
PASS: bad-filenames
PASS: bad-usage
PASS: concat-git-diff
XFAIL: context-format
PASS: copy-rename
PASS: corrupt-patch
PASS: corrupt-reject-files
PASS: create-delete
PASS: create-directory
PASS: criss-cross
SKIP: crlf-handling
XFAIL: dash-o-append
PASS: deep-directories
PASS: empty-files
PASS: false-match
PASS: fifo
PASS: file-create-modes
PASS: file-modes
PASS: filename-choice
PASS: git-binary-diff
PASS: git-cleanup
PASS: garbage
PASS: global-reject-files
PASS: inname
PASS: line-numbers
SKIP: merge
PASS: mangled-numbers-abort
PASS: mixed-patch-types
PASS: munged-context-format
PASS: need-filename
SKIP: no-mode-change-git-diff
PASS: no-newline-triggers-assert
SKIP: preserve-c-function-names
PASS: preserve-mode-and-timestamp
PASS: quoted-filenames
PASS: read-only-files
SKIP: reject-format
PASS: remember-backup-files
PASS: remember-reject-files
PASS: remove-directories
PASS: symlinks
PASS: unmodified-files
Testsuite summary for GNU patch 2.7.6
# TOTAL: 44
# PASS:  37
# SKIP:  5
# XFAIL: 2
# FAIL:  0
# XPASS: 0
# ERROR: 0

I'll see if I can spin up an x86 vm and give it a whirl to see what happens there. Have you tried the Oracle Studio compilers ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]