[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-readline] problem after upgrade to 6.3

From: Nuzhna Pomoshch
Subject: [Bug-readline] problem after upgrade to 6.3
Date: Tue, 30 Jun 2015 21:25:50 -0700

This has worked for many years (like about twenty :) )
without any problems.

After I upgraded from readline-6.2_p5 to readline-6.3_p8
last month, I am seeing some very undesirable

Basically, when I press the delete key at the end of a
line, I am getting put into command mode (don't want
that - want to stay in insert mode). Also, the prompt
changes to "(arg: 3) [typed command]" with subsequent
digits getting added to the end of the arg value

I am using bash-4.3_p33 with the following in my .bashrc

set -o vi
stty erase '^H'

Ctrl-v followed by the delete key produces the following:


I tried to search for a way to control this, but I am a very
marginal vim / command line editing user. Do you have
any idea what is going on? Thanks for your help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]