[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-recutils] recutils 1.8 required ldconfig to load librec.so.1

From: Charles Millar
Subject: [bug-recutils] recutils 1.8 required ldconfig to load librec.so.1
Date: Sat, 8 Jun 2019 20:49:01 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.7.0

It has been a few days since I built recutils 8.1 in Debian Buster so the error reported below is a rough approximation.

I downloaded check from the sourceforge site as suggested in README-dev.

However, I did not download some of the optional dependencies from the sources stated in the README-dev, Instead I installed the Debain packages for

?????? gnupg, libgpg-error and libgcrypt

?????? libcurl

?????? mdbtools.

As also noted in the README-dev I installed the Debian uuid-dev and libuuid1 packages.

Configure ran smoothly and there were no remarks at the conclusion concerning features that would not be installed. After "make" i ran "make check" and all tests were passed. Likewise, after installing, no errors were reported when i ran "make installcheck."

To check out the installation I ran "recsel --version" and I received, to the best of my recollection,

cannot load librec.so.1, no such file or directory. (I made sure that it did exist, etc.)

After searching the net I found a post that suggested using ldconfig, which i did and recutils now works.

So after all that explanation - did using the Debian packages cause this problem? if so is there an installation?? fix or should the README-dev?? contain a caveat about using the Debian packages for gnupg, etc.?

Charlie Millar

reply via email to

[Prev in Thread] Current Thread [Next in Thread]