[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-tar] tar -c <file> -f <file.tar> behavior change

From: Andrew Haninger
Subject: Re: [Bug-tar] tar -c <file> -f <file.tar> behavior change
Date: Sun, 17 Jul 2005 08:28:56 -0400

On 7/17/05, Paul Eggert <address@hidden> wrote:
> Sorry, I didn't quite get your bug report.  Can you give a specific
> example?  I just tried this:
> touch foo.c
> tar -c foo.c -f foo.tar
> tar -tvf foo.tar
> and it worked for me with tar 1.15.1: it created foo.tar with contents
> foo.c, and that sounds like it's what you wanted.  Here's the output I
> got from the last command:
> -rw-r--r-- eggert/eggert     0 2005-07-17 00:39:24 foo.c
Maybe this has something to do with it:

address@hidden:~# touch foo.c
address@hidden:~# tar -c foo.c -f foo.tar
tar: -f: Cannot stat: No such file or directory
tar: foo.tar: Cannot stat: No such file or directory
foo.c0000644000000000000000000000000010266446426010503 0ustar 
rootroottar: Error exit delayed from previous errors

I'm pretty sure that the distro-supplied version did the same thing
but I can't get it installed right now (slackware packages are bundled
with tar, so the chicken is eating the egg).

If I need to, can rebuild the box and see what happens.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]