[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-tar] Possible tar bug

From: Paul Eggert
Subject: Re: [Bug-tar] Possible tar bug
Date: Tue, 28 Dec 2010 11:57:00 -0800
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101208 Thunderbird/3.1.7

On 12/27/2010 11:40 AM, address@hidden wrote:
> I used to make one whole archive at once, backuping whole folder, but it 
> tends to be problematic when some tape becomes bad (I have to make whole 
> archive again than).
> So now I backup files in the folder alphabetically from A to Z (and numbers 
> first) because I can append from previous good record not having to start 
> from beginning with tens of GB. I started with some older tar version from 
> Ubuntu repository (1.20 or so) and:
> sudo tar -cMf /dev/st0 some_path/1*
> Then continued with letters up to G. It stucked with our error so I tried 
> again:
> sudo tar -cMf /dev/st0 some_path/G*
> from last record. Still the same problem. Than I tried files starting with H, 
> it took IIRC another one or two tapes (which worked fine so definitelly not 
> tape problem). After it I tried G again with no success. Upgraded to latest 
> Ubuntu repository tar (1.21 I think), nothing, than manually installed latest 
> tar from source and discovered which file is problematic, still not able to 
> append this single one.

This makes it sound like it's not connected to the -r option at all,
which is a surprise.

When you write "from last record", what does that mean?  Does it
mean that you executed this command:

sudo tar -cMf /dev/st0 some_path/G*

with an already-rewound tape, or that you did it without
rewinding the tape, or what?  How many times did it ask for
a new tape before it failed?  How long was the tape?  What
file did it fail on, and what does "ls -l" say for that file?

Also, what is the output of the following command?

env | grep TAR

reply via email to

[Prev in Thread] Current Thread [Next in Thread]