[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-tar] We found a bug in TAR

From: Bordács Péter [Info Station Kft.]
Subject: Re: [Bug-tar] We found a bug in TAR
Date: Mon, 14 May 2012 13:51:16 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20120420 Thunderbird/12.0

Dear Sergey,

Thanks your answers.

I created the archive with this command:
address@hidden:/# tar -cf /root/galaxyhungaria-2012-05-14.tar /Mentes/bergman/_var/www/galaxyhungaria/data/email/
tar: A kezdő „/” eltávolítása a nevek elejéről

I tried this command:

address@hidden:/# tar -t /root/galaxyhungaria-2012-05-14.tar

But after I'm waiting until 4 hours and nothing happened I press a "CTRL-C" key to break.
I can't see error message my cursor was blinked in the new line. After "CTRL-C" I become the prompt again.

If I extract from the archive I can't see error. If the extracting was done I become a cursor again:
address@hidden:~/tmp# tar -xf galaxyhungaria-2012-05-14.tar

But after the extracting the files are good. I think the real problem isn't the exactly the TAR. If I tried the extract in Midnnight Commander the problem is coming again. If I extract from the command line the extracting is success without failed files.

Sorry again I will compare and make a few test with the Midnight Commander. I think this is the wrong.


2012.05.14. 7:33 keltezéssel, Sergey Poznyakoff írta:
Bordács Péter [Info Station Kft.] <address@hidden> ha escrit:

If I make a backup which .tar.gz file size is bigger than ~2GB some
files content are corrupted.
Do you get any errors when trying to list the created archive (using
tar -t)?

Have you tried tar 1.26?

I attached two files.
These files were obtained using tar -x, right? Did tar report any
errors when extracting them?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]