[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: texinfo-tex-4.13a: texi2dvi fails to diagnose error

From: Karl Berry
Subject: Re: texinfo-tex-4.13a: texi2dvi fails to diagnose error
Date: Thu, 12 Jan 2012 16:25:40 -0800

Hi Eric, Jim,

(Back on this mail from two months ago, sorry.)

    > echo '\input texinfo.tex @bye' >txiversion.tex
    Ouch - this is a non-portable use of echo.  You CANNOT expect backslashes
    to make it through echo, but should use printf instead.

Excuse my skepticism, but on what platform(s) does echo '\i' fail to
pass the \?  It's been used here since inception (1992, I guess) and no
one has ever reported a problem.  Indeed, for many years it worked when
printf could not be assumed.  (Of course these days printf would be ok.)

I know the standard escapes such as '\r' can't be used portably, but
that's not the case here.
    I was surprised to find that texi2dvi was failing with no diagnostic.

Thanks for reporting that, Jim.  Looks to me like it was breakage
unknowingly introduced by someone "forcing" me to use set -e.  (Aside:
curmudgeon that I am, I hate set -e, even though everyone else seems to
love it.  Just seen so many warts introduced to placate it.  Like this
one.  Sigh.)

    if (
      printf %s\\n '\input texinfo.tex @bye' > txiversion.tex
      $TEX txiversion.tex </dev/null >txiversion.out 2>txiversion.err
    ); then

Ok, I munged that into place, thanks Eric.  Hope if (...) is portable
(in reality) as an if condition.  Never tried that before.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]