[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] wget-1.12-2359 alpha version

From: Ray Satiro
Subject: Re: [Bug-wget] wget-1.12-2359 alpha version
Date: Sat, 22 May 2010 15:11:22 -0700 (PDT)

Is there a web interface for the new repository? Somewhere we'll be able to 
click a link and download a zip of different revisions, like the old 
repository. I couldn't find it so I tried bazaar 2.1.1 for windows but it tells 
me the wget tree isn't available and I can't pull anything:
This branch has no working tree. Last revision is 2359. Action not yet 
supported by current app_suite.
 Today I tried accessing the web interface http://bzr.savannah.gnu.org/lh/wget 
but it tells me "loggerhead disabled due to unstability; if you're interesting 
in maintaining it, please contact us"
It would be nice to have a web interface like they do at github. I use many 
different computers and I've become used to accessing revision information 
through the web. 

As for msys fixes I see you fixed the linking issue in the last revision, bravo 
:) ipv6 and ssl config tests are still broken. In windows if you are going do a 
static link test for openssl you should link with winsock2 (openssl now uses 
winsock2) and gdi as well. So this will work:
gcc a.c -lssl -lcrypto -lws2_32 -lgdi32
regardless when wget is compiled with-ssl using mingw one would expect that 
instead of ssl crypto gdi it not be linked to any of those, just to eay32 and 
ssl32 (openssl dlls).
also the config ac shows lwsock32 -lws2_32 and indeed on compile both are 
linked. is there any reason for this, like maybe a trick for a universal binary 
or something? it doesn't seem logical. 

ipv6 fix is a little different and this goes to an argument that's come up 
before where if you are going legacy there apparently is a way to make a 
universal binary so that wget built with ipv6 support could? function on 
windows systems with winsock 1.1. well ok but really is wget set up for this 
and is it possible and is there any reason for it? i don't get that. regardless 
config is testing for getaddrinfo which is only winsock2, and according to the 
tcpip header file I have for it actually to be declared _WIN32_WINNT >= 0x0501. 
my suggestion is continue to test for getaddrinfo but fix for mingw

--- On Sat, 5/22/10, Giuseppe Scrivano <address@hidden> wrote:

From: Giuseppe Scrivano <address@hidden>
Subject: Re: [Bug-wget] wget-1.12-2359 alpha version
To: "Guillaume Turri" <address@hidden>
Cc: address@hidden
Date: Saturday, May 22, 2010, 2:41 PM

Hi Guillaume,

Guillaume Turri <address@hidden> writes:

> Indeed, according to this page
> http://wget.addictivecode.org/RepositoryAccess I thought the current
> repository was the Mercurial one.
> How could I have found it out if I haven't read this mailing list?
> Have I made a mistake and checked a wrong page?

Thanks for the suggestion, I have updated that page to link to the
Savannah page.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]