[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-wget] Name or service not known

From: Xeno
Subject: [Bug-wget] Name or service not known
Date: Tue, 27 Jul 2010 16:58:42 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100720 Lanikai/3.1.1

I was in an irc discussion about a wget problem I've been having. I'm not sure what info you will want so I'll just give the discussion.

<Daphron> I'm trying to download yaourt.
<Daphron> $ wget http://aur.archlinux.org/packages/package-query/package-query.tar.gz
<Daphron> But that only gives me this...
<Daphron> --2010-07-27 16:16:50-- http://aur.archlinux.org/packages/package-query/package-query.tar.gz
<Daphron> Resolving aur.archlinux.org... failed: Name or service not known.
<Daphron> wget: unable to resolve host address “aur.archlinux.org”
<Daphron> wget www.google.com works so why doesn't this work? (can any of you test it and see if it works for you?)
<micahcowan> WFM
<micahcowan> Sounds like a problem with your resolver, or possibly a proxy.
<Daphron> I have no idea how to fix that, anything to read?
<micahcowan> Not really... but it sounds like a problem with your DNS. You might edit that to point at some other DNS server. ...are you able to access that URL from a browser, or some other tool? <micahcowan> It might be worth a try to stick a "." after the "aur.archlinux.org": "http://aur.archlinux.org./...";.
<Daphron> added '.' didn't work
<micahcowan> Yeah, was worth a shot, but not very likely.
<micahcowan> What does "dig aur.archlinux.org" give you?
<Daphron> When I try to access the url in firefox it sucessfully downloads the file
<Daphron> ; <<>> DiG 9.6.1 <<>> aur.archlinux.org
<Daphron> ;; global options: +cmd
<Daphron> ;; Got answer:
<Daphron> ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5358
<Daphron> ;; flags: qr rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
<Daphron> ;; WARNING: recursion requested but not available
<Daphron> ;aur.archlinux.org. IN A
<Daphron> ;; ANSWER SECTION:
<Daphron> aur.archlinux.org. 3040 IN A
<Daphron> ;; Query time: 37 msec
<Daphron> ;; SERVER:
<Daphron> ;; WHEN: Tue Jul 27 16:36:40 2010
<Daphron> ;; MSG SIZE rcvd: 51
<micahcowan> Hm, maybe wget is using a proxy that firefox (and dig) aren't? What's "env | grep -i proxy" have to say?
<Daphron> I pasted into terminal and nothing happens
<micahcowan> Okay... you don't have proxy settings in /etc/wgetrc or ~/.wgetrc, do you? <micahcowan> Do you have the host and nslookup commands? Try "host aur.archlinux.org" and "nslookup aur.archlinux.org" <micahcowan> (And make sure wget is still not working for you - maybe it was a temporary issue?)
<Daphron> wget still not working. Nothing in wgetrc files
<Daphron> $ host aur.archlinux.org
<Daphron> aur.archlinux.org has address
<Daphron> aur.archlinux.org mail is handled by 10 mail.archlinux.org.
<Daphron> $ nslookup aur.archlinux.org
<Daphron> Server:
<Daphron> Address:
<Daphron> Non-authoritative answer:
<Daphron> Name: aur.archlinux.org
<Daphron> Address:
<micahcowan> I'm stumped then. Wget just uses the system library's "gethostbyname" function to resolve names, which is pretty standard. Apparently something's interfering with that, or maybe it's linked against a library that is naughty and provides its own version. I really don't know what to say at this point. <Daphron> BTW the git protocol has never worked for me on this computer but works on my other one. Think this is related? <micahcowan> Could be. Perhaps there's firewalling preventing the git protocol from working? <micahcowan> Don't know why someone would block name services, though, or why that would impact one program and not another.
|<-- cirzgamanti` has left freenode (Read error: Connection reset by peer)
<Daphron> Don't think so. I deactivated the firewall and git didn't work. Could try deactivating for wget
<Daphron> -
<Daphron> anyways, thanks for your help. I think I'll try the mailing list now and see if anyone else has some ideas.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]