[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Wget Question

From: Michael Tarkowski
Subject: Re: [Bug-wget] Wget Question
Date: Thu, 28 Jun 2012 11:49:03 +0000

I would like to thank everyone who has responded, a lot of good information was 
provided but unfortunately I still cannot connect with Wget and get the same 
error response.  The Tomcat server has othe Basic Auth pages and I can use Wget 
successfully with them but not the 1 page using digest auth.  Here is what I 
have tried without success.

- confirmed ID and password work from a browser.

- tried wrapping the ID and password in single quotes.

- tried using the --header option

- installed the latest version to eliminate the bug in earlier versions

- tried using curl -w -S -v -u admin:K0ny_2011Chrys1er --digest <URL_here>


Michael Tarkowski
Sales & Marketing Application Architecture
Chrysler Group LLC 
Office: +01.248.838.4866   Mobile: +01.248.891.5097
Email:  address@hidden
Mobile Text: address@hidden

-----Original Message-----
From: Tim Ruehsen [mailto:address@hidden 
Sent: Thursday, June 28, 2012 3:14 AM
To: address@hidden; Ray Satiro
Cc: Michael Tarkowski
Subject: Re: [Bug-wget] Wget Question

Am Thursday 28 June 2012 schrieb Ray Satiro:
> > From: Tim Ruehsen <address@hidden>
> >
> >To: address@hidden
> >Cc: Michael Tarkowski <address@hidden>
> >Sent: Wednesday, June 27, 2012 4:43 AM
> >Subject: Re: [Bug-wget] Wget Question
> >
> >Hi Michael,
> >
> >> I'm trying to use wget 1.13.4 from a command line to access a web 
> >> page using Digest Authentication and I keep getting HTTP/1.1 401 
> >> Unauthorized
> >> response.   Below is my code and the response.  Any suggestions would be
> >> appreciated.
> >> 
> >> wget --debug --server-response --user-agent="" --ignore-case 
> >> --user=admin --password=abc -O - 
> >>
> >>
> >>...
> >
> >I assume that you double checked username and password, e.g. by 
> >opening your URL with a web browser.
> >
> >Well, some servers need a proper "User-Agent" header in the request 
> >to behave as expected. Try again without --user-agent .
> >If it doesn't work, try it with --user-agent="Mozilla/5.0".
> >
> >If that still doesn't work, try simulating your web browser by 
> >providing additional header lines with --header option, especially 
> >the Accept and Accept-Language headers.
> also try curl and see what happens
> curl -v -u user:pass --digest
> might be related to
> http://savannah.gnu.org/bugs/?33830

I don't think so, since the bug relates to 'Version: 1.12-2.1' of wget.

Michael used 1.13.4, which is also in Debian SID. With that version, I can't 
reproduce the behaviour. The bug should be closed.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]