[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-zile] C-h under GNU screen

From: Reuben Thomas
Subject: Re: [Bug-zile] C-h under GNU screen
Date: Thu, 5 Jun 2008 00:18:35 +0100 (BST)
User-agent: Alpine 1.00 (DEB 882 2007-12-20)

On Wed, 4 Jun 2008, Micah Cowan wrote:

I suspect that the reason may well be related to the terminfo settings I
have for screen; "infocmp" gives the following output:

#       Reconstructed via infocmp from file:
/usr/share/terminfo/s/screen screen|VT 100/ANSI X3.64 virtual terminal,
       il=\E[%p1%dL, il1=\E[L, ind=^J, is2=\E)0, kbs=^H, kcbt=\E[Z,

As you can see, it gives ^H for kbs. However, stty -a has erase=^?; and
GNU Emacs (as I mentioned) correctly distinguishes C-h from backspace.

As you say, these settings are inconsistent. Zile doesn't use terminfo or stty directly; it uses ncurses. I've tried to get down and dirty with terminfo before but it only caused more problems than it solved, so I don't want to follow that route again.

I am however interested in eradicating the underlying bug here, if it still exists, so that in future Zile users will be less likely to run into it.

It may be that it's from an older screen setting, or perhaps it's distro-specific changes.

I'd be most grateful if you could shed any further light on this.

Be that as it may, the fact that there's a difference in behavior
between Zile and Emacs, suggests to me that it's worth looking into a
workaround for this problem.

I fear that this way lies only pain, especially in trying to hack around ncurses. Suggestions welcome, as usual.

http://rrt.sc3d.org/ | Enlightenment is understanding becoming belief

reply via email to

[Prev in Thread] Current Thread [Next in Thread]