[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-zile] Building Zile master head

From: Gary V. Vaughan
Subject: Re: [Bug-zile] Building Zile master head
Date: Tue, 24 Dec 2013 15:22:17 +1300

Hi Reuben,

On Dec 24, 2013, at 3:22 AM, Reuben Thomas <address@hidden> wrote:
> I just tried this. I got a fresh checkout, no problem. I ran ./bootstrap && 
> ./configure, fine. Then:
> zile (master)]$ make
>   ZLC      lib/zmacs/commands.lua
>   GEN      doc/zmacs.1
>   GEN      doc/dotzmacs.sample
>   GEN      lib/zmacs/doc/COPYING.lua
>   GEN      lib/zmacs/doc/FAQ.lua
>   GEN      lib/zmacs/doc/NEWS.lua
> help2man: can't get `--help' info from ./lib/zmacs/help2man-wrapper
> Try `--no-discard-stderr' if option outputs to stderr
> make: *** [doc/zmacs.1] Error 2
> make: *** Waiting for unfinished jobs....

Ugh :(

Well, that version had a tendency to generate an empty lib/zmacs/commands.lua 
if zlc
couldn't find all its dependencies.  I notice that I didn't remember to commit 
all my
recent changes back to the repo - though, I still really need to bail out 
sooner before
zlc outputs an empty file (added to my TODO list).  Let me know if the empty 
file is
your problem, and I'll figure out a way to diagnose it better.

> Running ./lib/zmacs/zmacs --help indeed produces no output, but gives no 
> error either.

I also added another patch to give a better error when bin/zmacs can't find an 
but since you're running lib/zmacs/zmacs (to set the paths automatically) that 

Please pull the latest version, and show me the differences between our output 
if you're
still stuck.  Here's my terminal log:

├!63517=git clean -dfx
Removing .autom4te.cfg
Removing .gitmodules
Removing ChangeLog
Removing GNUmakefile
Removing HACKING
Removing INSTALL
Removing Makefile
Removing Makefile.am
Removing Makefile.in
Removing aclocal.m4
Removing build-aux/do-release-commit-and-tag
Removing build-aux/gitlog-to-changelog
Removing build-aux/gnupload
Removing build-aux/install-sh
Removing build-aux/missing
Removing build-aux/mkrockspecs
Removing build-aux/release.mk
Removing build-aux/rockspecs.mk
Removing build-aux/sanity.mk
Removing build-aux/update-copyright
Removing config.log
Removing config.status
Removing configure
Removing doc/
Removing lib/zile/version.lua
Removing lib/zmacs/commands.lua
Removing lib/zmacs/doc/
Removing lib/zmacs/tests/atconfig
Removing lib/zmacs/zmacs
Removing m4/

From git.sv.gnu.org:/srv/git/zile
 * branch            master     -> FETCH_HEAD
Current branch master is up to date.

make: `build-aux/mkrockspecs' is up to date.
linking file './.autom4te.cfg'
linking file './GNUmakefile'
linking file './Makefile.am'
linking file './README-release'
linking file './build-aux/do-release-commit-and-tag'
linking file './build-aux/gitlog-to-changelog'
linking file './build-aux/gnupload'
linking file './build-aux/mkrockspecs'
linking file './build-aux/release.mk'
linking file './build-aux/rockspecs.mk'
linking file './build-aux/sanity.mk'
linking file './build-aux/update-copyright'
linking file './m4/ax_compare_version.m4'
linking file './m4/ax_lua.m4'
bootstrap: running: autoreconf --symlink --install
configure.ac:34: installing 'build-aux/install-sh'
configure.ac:34: installing 'build-aux/missing'
Makefile.am: installing './INSTALL'
bootstrap: creating `HACKING'
bootstrap: Done.  Now you can run './configure'.

├!63520=./configure LUA=lua52
## ------------------ ##
## Configuring zile 4 ##
## ------------------ ##

checking for a BSD-compatible install... /usr/local/bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/local/bin/gmkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking if lua52 is a Lua interpreter... yes
checking whether lua52 version >= 5.2... yes
checking for lua52 version... 5.2
checking for lua52 platform... unknown
checking for lua52 script directory... ${prefix}/share/lua/5.2
checking for lua52 module directory... ${exec_prefix}/lib/lua/5.2
checking for help2man... /usr/local/bin/help2man
checking for emacs... /usr/local/bin/emacs
checking Emacs version >= 23.1... yes
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating lib/zile/version.lua
config.status: creating lib/zmacs/zmacs
config.status: executing lib/zmacs/tests/atconfig commands

├!63521=make V=1
if ( touch doc/zmacs.1.w && rm -f doc/zmacs.1.w; ) >/dev/null 2>&1; \
        then                                            \
          builddir='.'                  \
          ./build-aux/missing --run             \
            /usr/local/bin/help2man                                     \
              '--output=doc/zmacs.1'                            \
              '--no-info'                               \
              '--name=Zmacs'                            \
              --include './lib/zmacs/man-extras'        \
              './lib/zmacs/help2man-wrapper';   \
          lua52 ./lib/zmacs/zlc ./lib/zmacs/zlisp/bind.zl 
./lib/zmacs/zlisp/buffer.zl ./lib/zmacs/zlisp/edit.zl ./lib/zmacs/zlisp/file.zl 
./lib/zmacs/zlisp/killring.zl ./lib/zmacs/zlisp/help.zl 
./lib/zmacs/zlisp/line.zl ./lib/zmacs/zlisp/lisp.zl ./lib/zmacs/zlisp/macro.zl 
./lib/zmacs/zlisp/marker.zl ./lib/zmacs/zlisp/minibuf.zl 
./lib/zmacs/zlisp/move.zl ./lib/zmacs/zlisp/registers.zl 
./lib/zmacs/zlisp/search.zl ./lib/zmacs/zlisp/undo.zl 
./lib/zmacs/zlisp/variables.zl ./lib/zmacs/zlisp/window.zl  > 
if ( touch lib/zmacs/doc/COPYING.lua.w && rm -f lib/zmacs/doc/COPYING.lua.w; ) 
>/dev/null 2>&1; \
        then                                                    \
          {                                                     \
            src=`echo 'lib/zmacs/doc/COPYING.lua' |sed -e 's|^.*/||' -e 
            echo 'return [==[';                                 \
            cat "./$src";                               \
            echo ']==]';                                        \
          } > 'lib/zmacs/doc/COPYING.lua';                                      
if ( touch lib/zmacs/doc/FAQ.lua.w && rm -f lib/zmacs/doc/FAQ.lua.w; ) 
>/dev/null 2>&1; \
        then                                                    \
          {                                                     \
            src=`echo 'lib/zmacs/doc/FAQ.lua' |sed -e 's|^.*/||' -e 
            echo 'return [==[';                                 \
            cat "./$src";                               \
            echo ']==]';                                        \
          } > 'lib/zmacs/doc/FAQ.lua';                                          
if ( touch lib/zmacs/doc/NEWS.lua.w && rm -f lib/zmacs/doc/NEWS.lua.w; ) 
>/dev/null 2>&1; \
        then                                                    \
          {                                                     \
            src=`echo 'lib/zmacs/doc/NEWS.lua' |sed -e 's|^.*/||' -e 
            echo 'return [==[';                                 \
            cat "./$src";                               \
            echo ']==]';                                        \
          } > 'lib/zmacs/doc/NEWS.lua';                                         
PACKAGE='zile'                          \
          lua52 ./lib/zmacs/mkdotzmacs.lua > 'doc/dotzmacs.sample'

SH=--[[                                             # -*- mode: lua; -*-
## Program initialisation
## Copyright (c) 2010-2013 Free Software Foundation, Inc.
## This file is part of GNU Zile.
## This program is free software; you can redistribute it and/or modify it
## under the terms of the GNU General Public License as published by
## the Free Software Foundation; either version 3, or (at your option)
## any later version.
## This program is distributed in the hope that it will be useful, but
## WITHOUT ANY WARRANTY; without even the implied warranty of
## General Public License for more details.
## You should have received a copy of the GNU General Public License
## along with this program.  If not, see <http://www.gnu.org/licenses/>.

# If LUA is not set, search PATH for something suitable.
test -n "$LUA" || {
  # Check that the supplied binary is executable and returns a compatible
  # Lua version number.
  func_vercheck ()
    test -x "$1" && {
      case `$1 -e 'print (_VERSION)' 2>/dev/null` in
        "Lua 5.2") LUA=$1 ;;

  for x in lua5.2 lua52 lua; do
    for dir in $PATH; do
      func_vercheck "$dir/$x"
      test -n "$LUA" && break
    test -n "$LUA" && break
    e="${e+$e\n}zmacs: command not found on PATH: $x"

test -n "$LUA" || {
  printf "${e+$e\n}zmacs: retry after 'export LUA=/path/to/lua52'\n" >&2
  exit 1

--:--  zmacs             Top (1,0)     

Gary V. Vaughan (gary AT vaughan DOT pe)

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

reply via email to

[Prev in Thread] Current Thread [Next in Thread]