[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-announce] [Chicken-users] CHICKEN 4.10.0 release candidate

From: Tim van der Linden
Subject: Re: [Chicken-announce] [Chicken-users] CHICKEN 4.10.0 release candidate 4 available
Date: Mon, 27 Jul 2015 20:32:07 +0900

Hi all

On Mon, 27 Jul 2015 08:58:16 +0200
Peter Bex <address@hidden> wrote:

> On Mon, Jul 27, 2015 at 08:47:56AM +0200, Sven Hartrumpf wrote:
> > ...
> > This is a known problem with newer GCC versions.
> > Your 2nd machine will need 4 hours or more :-(
> Correct; the [panic] you noted is actually part of the test; it checks
> that returning twice from a callback fails (which _should_ trigger a
> panic).  That's why it says "double-return from callback failed as it should."
> I agree this is somewhat surprising.

Indeed :)

> The GCC bug is known; I tried to explain this in the RC announcement
> mail.  It will probably disappear with CHICKEN 4.11, if it includes the
> new "argvector" branch.  If you would like to run the tests through to
> completion on this platform you can try installing the gcc-4.8 package
> or clang, and set the C_COMPILER variable to this compiler.

Hmm, this is strange, I tried with a previous version of the GCC compiler (4.8:

$ make PLATFORM=linux C_COMPILER=gcc-4.8 PREFIX=/home/tim/chicken-test/ install 

Again, same thing, stuck for over two hours on that same step.
So, I decided to try Clang:

$ make PLATFORM=linux C_COMPILER=clang PREFIX=/home/tim/chicken-test/ install 

Again, same thing. Before every run I clear out my build area so no remnants of 
the previous run remain. In the first few lines of the process I can see it 
uses the compiler I set in the variable:

clang  -L. -shared -Wl,-R"." srfi-69.import.o -o \
  -lchicken \
  -lm -ldl
clang  -L. -shared -Wl,-R"." extras.import.o -o \
  -lchicken \
  -lm -ldl

Also, when I use a compiler that does not exists, it complains so the variable 
is being picked up.

Yet, it seems to ignore the compiler variable for the tests as such a line 
reads (using the lines that keeps hanging):

/home/tim/chicken-test/chicken-4.10.0rc4/tests/../chicken 'apply-test.scm' 
-output-file 'a.c' -types ../types.db -ignore-repository -verbose -include-path 
'gcc' 'a.c' -o 'a.o' -c  -fno-strict-aliasing -fwrapv -DHAVE_CHICKEN_CONFIG_H 
-DC_ENABLE_PTABLES -Os -fomit-frame-pointer 

To my newbie eyes this looks like 'gcc' is hard-coded in there...somehow...? 
Whatever I do, it is picking up the correct compiler on start, but once the 
tests run it uses the "default" gcc setting...what am I messing up here?

> Anyway, thanks for testing, Tim!
> Cheers,
> Peter


reply via email to

[Prev in Thread] Current Thread [Next in Thread]