[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] 1.12 on MacOS X

From: Brian Campbell
Subject: Re: [Chicken-users] 1.12 on MacOS X
Date: Mon, 30 Jun 2003 13:48:33 -0400

On Monday, June 30, 2003, at 03:17  AM, Felix Winkelmann wrote:


Googling around for this, I stumbled over several occurrences of this
problem. Now, I don't have a 100% answer, so I recommend replacing
the line

extern char **environ;

in posix.scm with

char **environ;

You won't be able to use `current-environment', though, but I guess this
is not really crucial. Anyway, this is just a crude hack to get you

Thanks. That worked (well, I had to change it in posix.c also, since I didn't have a working chicken with which to compile posix.scm). current-environment is not that important to me, so I should be able to get by until this problem is worked out. What references did you find? I couldn't find anything useful by googling. The man page for environ doesn't seem to indicate anything out of the ordinary.

Note that I had reports that building the dynamically linked version
of Chicken fails on Jaguar, a couple of months ago. So if this still
doesn't work (depending on OS and libtool version), you should configure
Chicken with "--disable-shared".

Well, so far it seems to build, csi runs, and "make test" works fine without chicken being configured using "--disable-shared". What didn't work before? I can test it if you'd like. I'm running Jaguar (10.2.6, build 6L60).

Thanks for all the help,

(ps. Sorry if you get this twice. I forgot to hit "reply all" the first time)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]