[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] Call to unbound procedure c-ify-string in gen-lit in c-b

From: Tony Garnock-Jones
Subject: [Chicken-users] Call to unbound procedure c-ify-string in gen-lit in c-backend.scm?
Date: Sun, 26 Dec 2004 17:57:14 +0000
User-agent: Mozilla Thunderbird 0.8 (Macintosh/20040913)

Hi Felix, all:

I just updated to using the Darcs version of chicken, rebuilt the
system, and then tried to use it to recompile my SDL egg. The compiler
now dies processing sdl.scm, inside procedure "gen-lit", generating
code for a literal symbol "heap-node", when trying to apply
"c-ify-string". It complains:

        Error: call of non-procedure: #<unbound value>

I tried to debug the code in c-backend.scm, inserting calls to print;
c-ify-string prints as "#<procedure>" right up until you call it, when
the system fails with the error message above.

This is on MacOS X, with a c_defaults.h containing:

        /*** Program generated file: any edits may be lost ***/
        #define C_INSTALL_HOME "/opt/chicken/share/chicken"
        #ifndef C_INSTALL_LIB_HOME
        # define C_INSTALL_LIB_HOME "/opt/chicken/lib/chicken"
        #define C_BIN_DIR "/opt/chicken/bin"
        # define C_DEFAULT_TARGET_STACK_SIZE (128*1024)
        #define C_CC "gcc"
        #ifndef C_STACK_GROWS_DOWNWARD
        #define C_STACK_GROWS_DOWNWARD (1)
        #define C_INSTALL_BIN_HOME "/opt/chicken/bin"

Here's the output from the compilation:

        csc -C -I/sw/include/SDL -C -D_THREAD_SAFE -L -L/sw/lib \
                -L -lSDLmain -L -lSDL -L -framework -L Cocoa \
                -L -framework -L OpenGL -L -lSDL_ttf -L -lSDL_image \
                -L -lSDL_gfx -L -lSDL_net -s -o sdl.scm
        Error: call of non-procedure: #<unbound value>

*** Shell command terminated with exit status 70: /opt/chicken/bin/chicken sdl.scm -output-file sdl.c -dynamic -feature chicken-compile-shared -quiet
        make: *** [] Error 70

Strange, eh? I had previously been compiling the very same code okay
with the CVS version of chicken from a couple of weeks ago. I'll try
pulling the old CVS repository to narrow down the fault if you like,
but I'll also attach the SDL egg to see if anyone else can reproduce
or debug the fault :-/


Attachment: sdl.egg
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]