[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] chicken-setup quoting problem on CMake MinGW

From: Brandon J. Van Every
Subject: Re: [Chicken-users] chicken-setup quoting problem on CMake MinGW
Date: Fri, 01 Sep 2006 02:34:31 -0700
User-agent: Thunderbird (Windows/20060719)

felix winkelmann wrote:
On 8/31/06, Brandon J. Van Every <address@hidden> wrote:

I'm going to guess that because there are 4 quotes on this line,
something is absorbing 2 of 'em or some nonsense like that, probably
quoting the interior of the command and leaving E:\Program bare.

I think the latter quotes are only due to escaping in the error

I tried to simulate this situation by building a version on linux (ffrom
repo) with a prefix containing whitespace. Not surprisingly the autotools
build can't handle that (libtool bombs). CMake worked (modulo the
problem I talked about with missing - entering "make"
again works ok) and running "chicken-setup opengl" with paths and
library-paths properly set runs to completion.

So I guess this is a mingw issue.

No, probably a Windows Command Prompt issue. You did your stuff under a Bourne shell. I haven't tested under MSYS or Cygwin shells; maybe the problem will go away there. I'm in the middle of Autotools stuff right now, not gonna break focus...

Brandon Van Every

reply via email to

[Prev in Thread] Current Thread [Next in Thread]