[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] Msys install and "\"

From: Matthew David Parker
Subject: [Chicken-users] Msys install and "\"
Date: Sat, 9 Dec 2006 21:53:47 -0500 (EST)

I'm trying to install chicken-2.5 on windows in MSYS.

I tried using cmakeSetup to make MSYS makefiles, and then I compiled them
from within MSYS by typing "make" and "make install".  I had it install
to /bin within msys.  For some reason, the binaries don't seem to read any
command-line arguments.  For instance, I try:

$ csc
csc: no source files specified

The commands work ok if I run them in the regular windows terminal, but I
want to run them in MSYS so that I can use all my other libraries I've
installed in MSYS.

So, I tried compiling chicken using the regular ./configure script.  That
compiled ok, and these binaries can read the command-line arguments, so
they are almost exactly what I want.  However, for some reason chicken
uses a "\" instead of a "/" for the last slash when it runs some other
chicken command.

Like, if I run csc on a test file, it will try to run chicken, but it will
try to run the command:


Which it cannot find, so it fails.  Is there some way I can get chicken to
do a "/" instead?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]