[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] Issues installing the 9p egg.

From: Magnus Deininger
Subject: [Chicken-users] Issues installing the 9p egg.
Date: Thu, 06 Mar 2008 01:33:47 +0100

Hey dear mailing list,

Leonardo pointed me to a chicken egg for 9p, and i fell in love instantly. Now, 
I immediately went along and tried to install the egg... but unfortunately i 
get a fairly useless message telling me it's not working; basically i get this:

# chicken-setup -dnk 9p
  /usr/bin/csc -feature compiling-extension -k -s 9p-lolevel.scm
*** Shell command terminated with exit status 1: /usr/bin/chicken 
9p-lolevel.scm -output-file 9p-lolevel.c -dynamic -feature 
chicken-compile-shared -quiet -feature compiling-extension
Error: shell invocation failed with non-zero return status
"/usr/bin/csc -feature compiling-extension -k -s 9p-lolevel.scm"

I did install the iset egg, as was pointed out on the wiki:
# chicken-setup -l
iset                                                Version: 1.4 

Other than that i pretty much followed orders from Leonardo and tried his new 
ebuild on the gentoo-lisp overlay. It appears to be working fine on x86, but 
I'm on x86-64, so maybe that would be the issue? I wouldn't know... I'm kinda 
lost :).

That's the only egg i got installed though, so maybe it just needs some other 
egg too?
I'd really like to get dirty with chicken (for einit ;)) but that means i need 
a 9p2000 transport lib :).

Magnus Deininger
In 5 Schritten zur eigenen Homepage. Jetzt Domain sichern und gestalten! 
Nur 3,99 EUR/Monat!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]