[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Problems Installing the lookup-table Egg

From: Kon Lovett
Subject: Re: [Chicken-users] Problems Installing the lookup-table Egg
Date: Sat, 11 Dec 2010 10:07:03 -0800

On Dec 11, 2010, at 3:59 AM, Ehsanul Hoque wrote:


Awesome, it works now. Thanks! I'll probably compile from source anyhow.

I guess the zmq egg might just have the very same compatibility problem then?

No, not the same issue as lookup-table, the "module body string inclusion" feature. Sorry, at this time I do not know what happened with the failure to install zmq w/ Chicken 4.2.0.

Warnings like:

Warning: redefinition of imported value binding: errno

Warning: global variable `zmq#message-mutex-set!' is never used

maybe annoying but are not necessarily problem indicators. More compile-time debug output is needed. I have seen a compile failing to produce the .import file from an apparently successfully compiled module & fixed it. I just do not remember what the cause.

However this usually is a problem:

Warning: exported identifier for module `lookup-table' has not been defined: dict-print

Best Wishes,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]