[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] Help with udp6 / socket

From: Scott McCoid
Subject: [Chicken-users] Help with udp6 / socket
Date: Mon, 16 Feb 2015 10:22:28 +0100


I'm reasonably new to chicken-scheme (and scheme in general), and I'm having trouble with the udp6 (and likewise, socket) eggs. I'm trying to run the example code, but the connection is always refused. 

Error: (socket-receive!) cannot read from socket - Connection refused: #<socket fd:4 af/inet sock/dgram>

I looked into the socket code and it seems that this is probably not the fault of these eggs per se, but probably something I'm doing wrong. For example, the %socket-receive! function makes a call to the <sys/socket.h> recv function, which always returns -1. I've tried using other port numbers to connect to, but this doesn't seem to make a difference. 

I'm on Mac OS 10.10.2 using chicken scheme v. (stability/4.9.0) (rev 8b3189b)

I'm happy to help track this down if it's a bug, just let me know. 


For reference I've tried this example as well as a simplified version using (udp-recv s 64)
(use udp6)
(define s (udp-open-socket))
(udp-connect! s "localhost" 13)  ; daytime service
(udp-send s "\n")
(receive (n data host port) (udp-recvfrom s 64)
  (print n " bytes from " host ":" port ": " data))
(udp-close-socket s)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]