[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] Bug in csc -deploy on OSX

From: Ryan Senior
Subject: [Chicken-users] Bug in csc -deploy on OSX
Date: Thu, 30 Jul 2015 08:41:08 -0500

I think I have found a bug in the linkage of OSX standalone binaries. I run a command like:

csc -deploy nodes-script.scm

I get a nodes-script directory with two files like I would expect:

$ ls nodes-script/
libchicken.dylib  nodes-script

But when I run otool -L on the nodes-script binary, it shows that it's linked with the system libchicken, not the one included in the nodes-script directory:

$ otool -L nodes-script/nodes-script
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 1153.18.0)
/usr/local/lib/libchicken.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1213.0.0)

Is this a bug? I went through the same process on a Debian VM and found the binary was linked correctly (i.e. the nodes-script binary was linked to the local libchicken).

I have installed chicken via 'brew install chicken', with version info below:

$ csc -version
(c) 2008-2014, The Chicken Team
(c) 2000-2007, Felix L. Winkelmann
Version (stability/4.9.0) (rev 8b3189b)
macosx-unix-clang-x86-64 [ 64bit manyargs dload ptables ]
bootstrapped 2014-06-07



reply via email to

[Prev in Thread] Current Thread [Next in Thread]