[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Windows deployment - Numbers egg

From: Peter Bex
Subject: Re: [Chicken-users] Windows deployment - Numbers egg
Date: Sun, 4 Oct 2015 15:30:58 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

On Sun, Oct 04, 2015 at 08:50:59PM +0800, Robert Herman wrote:
> Matt,
> "csc -deploy -static Pi-Ch.scm" creates a deploy directory, and the
> resulting executable is 1.6MB vs 77KB, but it still throws the "cannot the
> load the extension: numbers".
> I then tried putting libchicken.dll in the deploy directory that was
> created, and making a numbers.dll file, since Windows does not
> use .so files, only .dll.

I think this is incorrect; looking at my VM mingw install, and all the eggs
(even all the import libraries from CHICKEN core), it uses .so for all the
dynamically loaded extensions.  And if I install it normally, and type
(use numbers) at the REPL, it prints that it's loaded /path/to/

Renaming manually is something I would definitely not recommend, because
then you would be messing with the names that CHICKEN expects.

> I used chicken-install -r to retrieve the numbers
> egg into the current directory. I then tried "csc -dll numbers.scm" and it
> created I tried putting it in the deploy directory, but no
> luck. I changed the .so to .dll, and again no luck.

I've tried to do it "by the book" on mingw (msys):

$ /path/to/chicken-install.exe numbers
$ echo '(use numbers) (print 1/2)' > foo.scm
$ /path/to/csc.exe -deploy -X numbers-syntax foo.scm
$ /path/to/chicken-install.exe -deploy -prefix foo numbers
$ # To prove that it's not loading numbers from install dir:
$ /path/to/chicken-uninstall.exe numbers
$ ./foo/foo.exe

This works perfectly.  The book, incidentally, is here:

Hope this helps,

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]