[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] eggs failing to install on freebsd 12

From: Gavin Reade
Subject: [Chicken-users] eggs failing to install on freebsd 12
Date: Sun, 17 Feb 2019 13:45:51 +0000

Hi All,

I'm having trouble installing some eggs on freebsd 12, in particular breadline and iup.
The build fails with (in the case of breadline) an error with readline.h not being found.
In the case of iup it fails with ffi.h not being found.

It turns out that both these header files are installed in /usr/local/include.  A similar issue was raised in the freebsd users list (related to compiling C source) and the fix was to define a $C_INCLUDE_PATH variable.
I have tried this and it makes no difference.
I have also edited the CSC5 command in the "" to "export CHICKEN_CSC='/usr/local/bin/csc5 -I /usr/local/include'
However this gets over written when I run the chicken-install5 iup.

Has anyone had a similar experience?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]