[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: downloaded latest still not guess system type

From: Jacob Bachmeyer
Subject: Re: downloaded latest still not guess system type
Date: Mon, 17 Oct 2022 20:22:20 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090807 SeaMonkey/1.1.17 Mnenhy/

Jonathan Bedford wrote:
./config.guess: unable to guess system type

This script, last modified 2007-03-06, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from*checkout*/config/config/config.guess


config.guess timestamp = 2007-03-06

uname -m = aarch64
uname -r = 5.10.66-22-rockchip-g882edb720d40
uname -s = Linux
uname -v = #rockchip SMP Sat Sep 17 11:11:07 UTC 2022

That is not the latest version, and is so ancient that the URLs for the latest versions have changed since it was released. Try: (in the source directory)

$ wget -O config.guess $ wget -O config.sub

That version of config.guess is likely older than your CPU architecture. Replacing config.guess and config.sub with current versions may be all you need to do to solve the problem; if so and this is a current release, reporting this issue to the maintainers may get them to update the versions of those scripts they ship in the release tarball.

-- Jacob

reply via email to

[Prev in Thread] Current Thread [Next in Thread]