[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: df --output

From: Bernhard Voelker
Subject: Re: df --output
Date: Sat, 29 Sep 2012 23:29:16 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120825 Thunderbird/15.0

On 09/24/2012 07:36 AM, Jim Meyering wrote:
> Bernhard Voelker wrote:
>> Just a status update:
>> I have to move the code around a bit for Padraig's suggestions
>> * to print "total" instead of a "-" in the target field if the
>>   source field is unused, dash-in-the-target-field
>> * to not permit the abbreviation of field names.
>> It seems that I can improve the memory structures regarding
>> field_defaults and columns as a side effect - I didn't like
>> the doubling of the width, caption and align fields anyway.
>> ;-)
>> I'm not that far away from the goal, but I maybe won't have
>> too much free time for this in the next few days.
>> Please be patient.
> Thanks for the update.
> Take your time.

Here you are (see attached):

[PATCH 20/20] df: print "total" in grand total's target field if no source
[PATCH 19/20] df: cleanup comments regarding double blank after
[PATCH 18/20] df: add a test for the --output option
[PATCH 17/20] df: document the new --output option
[PATCH 16/20] df: plug two minor memory holes detected by valgrind
[PATCH 15/20] df: add new --output option
[PATCH 14/20] df: enhance comment describing history
[PATCH 13/20] df: give posix_format variable a better scope
[PATCH 12/20] df: cleanup header_mode handling regarding --inodes
[PATCH 11/20] df: minor cleanup to improve readability
[PATCH 10/20] df: remove remainder of pre-mixed fields support
[PATCH 09/20] df: add basic support for mixed block and inode fields
[PATCH 08/20] df: print '-' into the target column of the total line
[PATCH 07/20] df: only sum up grand total if required
[PATCH 06/20] df: remove now-obsolescent condition
[PATCH 05/20] df: use enum value for long option --total
[PATCH 04/20] df: apply ambsalign to the last field with
[PATCH 03/20] df: rework internal processing of output columns
[PATCH 02/20] df: rename some displayable fields
[PATCH 01/20] df: move the call of get_header from get_dev to main

The bigger/important changes are in the patches 03, 09, and 15.


  $ src/df -h --tot --o=target,pcent,ipcent / /home
  Mounted on Use% IUse%
  /           65%   32%
  /home       65%    2%
  total       65%    5%

Have a nice day,

Attachment: df-output.patch.bz2
Description: application/bzip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]