[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

struct rusage redefinition issues on ppc - gnu time-1.7

From: Aijaz Baig
Subject: struct rusage redefinition issues on ppc - gnu time-1.7
Date: Tue, 25 Jun 2013 13:22:32 +0530

Im trying to compile Gnu time 1.7 for a powerpc system using the windriver build system which is based on yocto.

The build fails with an error at resuse.h:44:error: redefinition of 'struct rusage'.

On searching the internet foundĀ  benoit sibaud facing same problem on solaris. He commented out system definition and it worked for him. For me however it doesn't work. On doing that itvfails to link the various object files time.o getopt.o error.o resuse.o and version.o.

On another thread here, paul eggert's suggestion to Jim McMaster who seemed to be facing something simiar while compiling it for solaris 8 is to define HAVE_WAIT3. I've tried that too but it fails as well. And its again while linking the aforementioned object files.

Please help me in getting this fixed. Where do I check for the build logs in detail. As what exactly is causing the linking to fail? By the way errors of the sort 'crt1.o: No such file: No such filevor directory are link time errors right? At times I've seen people saying they signify a corrupted libc. Hoeever when i manually search for it in my sysroot i can find it.

Im confused. Pls elaborate. Keen to hear.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]