[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: struct rusage redefinition issues on ppc - gnu time-1.7

From: Bob Proulx
Subject: Re: struct rusage redefinition issues on ppc - gnu time-1.7
Date: Tue, 25 Jun 2013 21:33:30 -0600
User-agent: Mutt/1.5.21 (2010-09-15)

Aijaz Baig wrote:
> hi.


> Im trying to compile Gnu time 1.7 for a powerpc system using the windriver
> build system which is based on yocto.

Thanks for the report.  However you are reporting a bug in the time
project to the coreutils project.  Time and coreutils are two separate
projects.  GNU time doesn't use any bug trackers.  Therefore this bug
to the coreutils project will never be seen by the GNU time

The best reporting address for problems with time is the
address@hidden mailing list.  It isn't a good place.  It is
only the best place relative to any other reporting address.

The GNU time project has actually been quite dead for many, many
years.  However the official maintainer keeps saying that a new
release will happen every time he is asked.  Therefore the project
sits in a perpetual limbo betwixt and between.

In my opinion the best way to compile GNU time is to grab the patched
sources from one of the many software distributions.  I am the
maintainer for Debian and so my biased opinion would be to use the
Debian patched sources.  But most of the patches have been shared all
around by now and so any of the distros are likely very similar at
this stage.

Rather than discuss the time project here in coreutils project
discussion list where it won't ever be found by current or future time
maintainers I am going to reply to this message and send it to
bug-gnu-utils where it would be expected.  We can follow-up to the
discussion there.


> The build fails with an error at resuse.h:44:error: redefinition of 'struct
> rusage'.
> On searching the internet found  benoit sibaud facing same problem on
> solaris. He commented out system definition and it worked for him. For me
> however it doesn't work. On doing that itvfails to link the various object
> files time.o getopt.o error.o resuse.o and version.o.
> On another thread here, paul eggert's suggestion to Jim McMaster who seemed
> to be facing something simiar while compiling it for solaris 8 is to define
> HAVE_WAIT3. I've tried that too but it fails as well. And its again while
> linking the aforementioned object files.
> Please help me in getting this fixed. Where do I check for the build logs
> in detail. As what exactly is causing the linking to fail? By the way
> errors of the sort 'crt1.o: No such file: No such filevor directory are
> link time errors right? At times I've seen people saying they signify a
> corrupted libc. Hoeever when i manually search for it in my sysroot i can
> find it.
> Im confused. Pls elaborate. Keen to hear.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]