[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems cloning

From: Andrew Burgess
Subject: Problems cloning
Date: Fri, 28 Apr 2017 10:18:20 +0100
User-agent: Mutt/1.6.1 (2016-04-27)


When I follow the instructions from here:

to clone the coreutils git repository I run into an error, here's my
terminal output:

  $ git --version
  git version 2.12.2
  $ git clone git://
  Cloning into 'coreutils'...
  remote: Counting objects: 169874, done.
  remote: Compressing objects: 100% (40066/40066), done.
  remote: Total 169874 (delta 129539), reused 169765 (delta 129464)
  Receiving objects: 100% (169874/169874), 31.57 MiB | 4.35 MiB/s, done.
  error: object a6727941433ee1c91a20ede6cb381af1d18c566d: 
missingSpaceBeforeDate: invalid author/committer line - missing space before 
  fatal: Error in object
  fatal: index-pack failed

I've tried the clone on 3 different machines all running different
versions of git so I'm reasonably confident that the repository
corruption is in the upstream repository.

I'm no git expert so wont even start to guess how this happened, or
how to fix it, but thought I should let you know.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]