[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Demexp-dev] Problem with preference saving ?

From: Thomas Petazzoni
Subject: Re: [Demexp-dev] Problem with preference saving ?
Date: Tue, 27 Sep 2005 22:20:50 +0200
User-agent: Mozilla Thunderbird 1.0.6 (X11/20050802)


David MENTRE a écrit :
> 2005/9/27, Thomas Petazzoni <address@hidden>:
>>However, I wasn't able to login on the locally running demexp server
>>with root/demexp. Is it really the default root password ?
> Yes. I have checked in 0.6.2 sources, in
> """
> Function [[initialize_default_participant_base]] initializes the base of
> participants with an empty base containing only one participant: an
> administrator of name ``[[root]]'', of login ``[[demexp]]'' and
> belonging to the group [[administration_group]].
> \nextchunklabel{code:root-login}
> <<>>=
> let administration_group = "admin"
> let classification_group = "classifier"
> let initialize_default_participant_base () =
>   the_participant_base := create_participant_base ();
>   ignore(add_participant "root" "demexp" [administration_group;
>                                           classification_group]);
>   check_invariants ()
> @
> """
> Have you tried following procedure?
> 1. demexp-gtk2-client demexp://localhost:50000
> 2. In Preferences, set login/pass to root/demexp
> 3. quit and restart client with demexp-gtk2-client demexp://localhost:50000

Okay, I've tried this. The client correctly sends root/demexp, according
to the following 'ngrep':

crazy:/home/thomas# ngrep -d lo port 50000
interface: lo (
filter: (ip or ip6) and ( port 50000 )
T -> [AP]
  address@hidden ...................................root....demexp..

However, I still got the « login invalid » dialog box. Here are the logs
of the server when run with -d:

address@hidden:~$ demexp-server -d
<0>2005-09-27T22:16:26+0200 demexp server (0.6.2 -- U2: Unscalable &
  demexp server comes with ABSOLUTELY NO WARRANTY. This program is free
  software, and you are welcome to redistribute it under certain conditions

<0>2005-09-27T22:16:26+0200 server: use bases 'bases.dmxp'
<0>2005-09-27T22:16:26+0200  File "bases.dmxp" does not exists. Don't
load bases.
<0>2005-09-27T22:16:26+0200 server: opening main socket (
<0>2005-09-27T22:16:26+0200 server: ready
<0>2005-09-27T22:16:28+0200 RPC login(1, "root", **passw**)
<0>2005-09-27T22:16:28+0200  => participant 'root' failed to log in,
remains Anonymous (cookie:150854162)
<0>2005-09-27T22:16:29+0200 RPC get_timestamps(150854162)
<0>2005-09-27T22:16:29+0200 update timestamp list
<0>2005-09-27T22:16:29+0200 RPC max_question_id(150854162)
<0>2005-09-27T22:16:29+0200  => return max_question_id:-1
<0>2005-09-27T22:16:29+0200 RPC max_tag_id(150854162)
<0>2005-09-27T22:16:29+0200  => return max_tag:-1

I must be doing something really really wrong. But I can't see what. Is
the message regarding the non-existing bases.dmxp a problem ?


PETAZZONI Thomas - address@hidden
http://{thomas,sos,kos} - Jabber: address@hidden
Fingerprint : 0BE1 4CF3 CEA4 AC9D CC6E  1624 F653 CB30 98D3 F7A7

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]