[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] [bug #46117] Denemo fails to start on OSX 10.10.5

From: Jeremiah Benham
Subject: Re: [Denemo-devel] [bug #46117] Denemo fails to start on OSX 10.10.5
Date: Thu, 15 Oct 2015 21:11:08 -0500

What if we run:
sw_vers -productVersion

This produces 10.6.8 on my system. We can pipe this into to cut or a regex "." separating into the variables majorVersion minorVersion microVersion. Then if minorVersion is greater than 9 then we run your script. Would that work or do you have any idea why your system is turning those libs into symlinks?


On Wed, Oct 14, 2015 at 7:17 PM, Jeremiah Benham <address@hidden> wrote:
---------- Forwarded message ----------
From: "Rakesh Babu" <address@hidden>
Date: Oct 9, 2015 9:16 PM
Subject: [bug #46117] Denemo fails to start on OSX 10.10.5
To: "Jeremiah Benham" <address@hidden>, "Rakesh Babu" <address@hidden>, "Richard Shann" <address@hidden>, <address@hidden>

Follow-up Comment #5, bug #46117 (project denemo):

Just a follow-up, I was able to re-link the symlinks in using some
bash magic adapted from here
and was able to successfully start the application.

The first step I ran was to fix the symlinks using this command: find ./
-lname './*'      -exec sh -c 'ln -snf "../../../../$(readlink
"$0")" "$0"' {} ;

The next step was to use the symlinks utility to simplify the symlinks to the
current directory (

Should I place this in the file somehow? I am still not sure how it turned into symlinks on your machine also.

Thanks for testing this out!



Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]