[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] 2.0.0 and 1.2.4 bad font

From: Richard Shann
Subject: Re: [Denemo-devel] 2.0.0 and 1.2.4 bad font
Date: Tue, 20 Oct 2015 11:13:33 +0100

On Mon, 2015-10-19 at 00:17 +0200, Lars Björnfot wrote:
> >> The 2.0.0 zip worked. It creates denemo.ttf in 
> >> C:\Apps\denemo-2.0.0\usr\share\fonts\truetype\denemo
> >presumably you extracted the zip file to C:\Apps\ ???
> Yes.
> >> The 2.0.0 installer now also works when i re-installed it. 
> >> Fonts are OK even though there is no C:\Windows\Fonts\denemo.ttf.
> >Hmm, that is surprizing. But I have seen the most bizarre behavior from 
> >windows, and it may be that in your version it is supporting fonts somewhere 
> >else...
> My guess is:
> By running denemo.exe in C:\Apps\denemo-2.0.0\... it tells Windows about the 
> fonts, and Windows makes them available for other applications too. 
> And the generated *.ttf files then gets locked.  I tried to delete a 
> C:\Apps\denemo-0.0.0 after unzip and run, but Windows complained about files 
> locked. 
> Screenshot attached. 
> Rough translation is: "Cannot finish the action because the file is open in 
> System".
> After reboot I could delete them. 
yes, I see that quite often when trying to remove the fonts from C:
\Windows\Fonts so I think you are right that the system has locked the
font after running the Denemo.bat file, until re-boot.
> >> The installer gave error:   Invalid file handle 32 
> >Did that appear in the full-screen display that the installer uses? or in 
> >some popup window (entitled? ...) I haven't ever seen that, it could be 
> >something entirely local to you, of course.
> It was a separate popup. (attached #2) 
> Title "Denemo 0.0.0 for Microsoft Windows - Please re-boot when d..."
So that is the installer talking, I don't think I've seen that one
> I'm happy to help troubleshoot. :-)
> I think this version is much more stable than the previous!
> The only problem I had is it hanged, with a modal dialog behind another 
> window. Could see part of it but no chance to click it.

Was this while in one of the new property editors? (Score Properties
Editor, Staff Properties Editor ...). When you execute a command inside
those then the command may run a non-modal dialog which you can't
interact with before dismissing the editor window. I've tried to get rid
of these but some may be lurking.
If it is some other scenario that you can reproduce I would be grateful
for details...


> Lars

reply via email to

[Prev in Thread] Current Thread [Next in Thread]