[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 17 & 20 November Downloads

From: Joe Wilkinson
Subject: Re: 17 & 20 November Downloads
Date: Sun, 21 Nov 2021 15:15:25 +0000
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Thunderbird/91.3.2

Hi Richard,

I have attached a simple file.

I don’t know what you mean by saying put lilypond in the preferences but I tried just the word lilypond (should it have been lilypond-windows.exe?)

I tried both and got a report that lilypond could not be found and that Typeset was not possible.

There are two possible routes to lilypond on my PC

The separately downloaded Lilypond

        C:\Program Files (x86)\LilyPond\usr\bin\lilypond-windows.exe



I have several versions of Denemo and can change Den21Nov to one of the others, eg Den17Nov

If I use a downloaded denemo after Nov 17 – Nov 17, 20 or 21, I cannot get the attached file to Typeset with either route

If I use October 20th's (the previous version I downloaded  with none between) I can use either string to Typeset the file, or just lilypond-windows.exe

Summat has happened??🙁


On 21/11/2021 11:52, Richard Shann wrote:
On Sat, 2021-11-20 at 17:19 +0000, Joe Wilkinson wrote:
I was using a downloaded version of Lilypond and had preferences set
it: C:\Program Files (x86)\LilyPond\usr\bin\lilypond-windows.exe
It exists and typesets .ly files
I've downloaded and tested last night's build on a Windows 10 laptop,
it is typesetting with the built-in LilyPond ok.
If a File->New score does not typeset first test is to change the prefs
back to just "lilypond" and see if the built-in LilyPond works. If so
use File->New the File->Export->Export as LilyPond and then try to
typeset the resultant file with your 
C:\Program Files (x86)\LilyPond\usr\bin\lilypond-windows.exe

if that works then the finger of suspicion would point to a (possibly
invisible) typo in the prefs field (look in .denemo-2.5.6/denemorc for
the string, copy and paste it into the prompt ...) or some
bug in Denemo handling windows paths (surely would have surfaced
sometime in the past 20 years...).



On 20/11/2021 16:49, angelaandjoe.wilkinson wrote:
Hi Richard,
I just tried to run the 17 November download on an existing, 
previously successful, file and it wouldn't typeset, directing me
the Lilypond Window.
Typesetting ...Error launching lilypond! Message is Failed to
helper program (No such file or directory)

I get the same with a simple scale in the 20 Nov Download, but not 
with previous Oct 20th.
Best wishes

Attachment: ScaleOfCMaj2Bars.denemo
Description: XML document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]