[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Where is my mind?

From: Robert Bichage
Subject: [Discuss-gnuradio] Where is my mind?
Date: Tue, 7 Dec 2004 00:50:17 -0500 (EST)

I'm losing it one bit at a time ...

the issue is, I can't seem to get gnuradio-0.9 to compile without giving
me errors (I'm the guy who wants to run and see the ATSC examples; 2.x
compiled very fine for me but this 0.9 is a different breed of animal
 cppunit/examples/hierarchy/BoardGameTest.h lacked an iostream include
that was easy enough to fix but the latest batch of errors ... I
confess that I am not a programmer at all but if despite this flaw anyone
should see fit to save me from utter madness I will be eternally
greatful ... 

the details:
gcc 3.4.2
Fedora Core 2
autoconf 2.59
automake 1.9.2
... blah  ... (I have all the required versions -or higher-  of all the
required packages installed, I think, at least as outlined by the readme 
the problem:
I run ./bootstrap; ./configure; make; make install
and everything is fine and dandy until:
In file included from ./GrFIRfilterCCC.h:31,
                 from GrFIRfilterCCC.cc:28:
../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h: In member function
`virtual float VrDecimatingSigProc<iType, oType>::averageInputUse(int)':
../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:60: error:
`history' undeclared (first use this function)
../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:60: error: (Each
undeclared identifier is reported only once for each function it appears
../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:61: warning: no
return statement in function returning non-void
../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h: In member function
`virtual int VrDecimatingSigProc<iType,
../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:66: error: there
are no arguments to `getUpstreamModuleN' that depend on a template
parameter, so a declaration of `getUpstreamModuleN' must be available


I checked the included files ... VrSigProc turned out to be empty so I
just downloaded a copy from the CVS and overwrote the existing one from
the package I used - no go, same error.

I looked into VrHistoryProc.h and history (the first suspect), does indeed
have an alibi - he/she's an unsigned short int;

I know everyone is cruising along on 2.x but if anyone has any clue what I
could be doing wrong (and its almost certainly me!) please let me know ...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]