[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Where is my mind?

From: Robert Bichage
Subject: Re: [Discuss-gnuradio] Where is my mind?
Date: Wed, 8 Dec 2004 09:40:54 -0500 (EST)


Some sort of return to sanity ... this might be of use to anyone else who
upgraded their version of Fedora core and tried to recompile gnuradio ...

ok, in the file cppunit/examples/hierarchy/main.cpp I think an iostream
include is missing, so just add #include <iostream.h> at the beginning of
the file;

The second problem was a namespace problem ... when I upgraded to Fedora
core 3 it appears I also picked up a new version of g++ - version 3.4.2 to
be exact; this version is a lot stricter in enforcing the ansi c++ name
space convention - so with standard library includes, maybe add use
namespace std; after the includes or better still use std:: before the
functions themselves; also, "unqualified names will no longer find members
of a dependent base" so use "this->" with all the variables you're
referencing from the headers in the extending functions and it should
the relevant offenders are in the pspectra/vrp directory and if you've
tried compiling with 3.4.2 you probably know what I'm going on about ...
my reference was this:


Hopefully this saves someone else the headaches I had...it seems to
compile now but I'm working through the errors one by one to update all
the instances ...


On Tue, 7 Dec 2004, Robert Bichage wrote:

> I'm losing it one bit at a time ...
> the issue is, I can't seem to get gnuradio-0.9 to compile without giving
> me errors (I'm the guy who wants to run and see the ATSC examples; 2.x
> compiled very fine for me but this 0.9 is a different breed of animal
> altogether...);
>  cppunit/examples/hierarchy/BoardGameTest.h lacked an iostream include
> that was easy enough to fix but the latest batch of errors ... I
> confess that I am not a programmer at all but if despite this flaw anyone
> should see fit to save me from utter madness I will be eternally
> greatful ... 
> the details:
> gcc 3.4.2
> Fedora Core 2
> autoconf 2.59
> automake 1.9.2
> ... blah  ... (I have all the required versions -or higher-  of all the
> required packages installed, I think, at least as outlined by the readme 
> file);
> the problem:
> I run ./bootstrap; ./configure; make; make install
> and everything is fine and dandy until:
> "
> In file included from ./GrFIRfilterCCC.h:31,
>                  from GrFIRfilterCCC.cc:28:
> ../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h: In member function
> `virtual float VrDecimatingSigProc<iType, oType>::averageInputUse(int)':
> ../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:60: error:
> `history' undeclared (first use this function)
> ../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:60: error: (Each
> undeclared identifier is reported only once for each function it appears
> in.)
> ../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:61: warning: no
> return statement in function returning non-void
> ../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h: In member function
> `virtual int VrDecimatingSigProc<iType,
> oType>::checkOutputSamplingFrequency(float)':
> ../../../../src/pspectra/lib/vrp/VrDecimatingSigProc.h:66: error: there
> are no arguments to `getUpstreamModuleN' that depend on a template
> parameter, so a declaration of `getUpstreamModuleN' must be available
> ...
> I checked the included files ... VrSigProc turned out to be empty so I
> just downloaded a copy from the CVS and overwrote the existing one from
> the package I used - no go, same error.
> I looked into VrHistoryProc.h and history (the first suspect), does indeed
> have an alibi - he/she's an unsigned short int;
> I know everyone is cruising along on 2.x but if anyone has any clue what I
> could be doing wrong (and its almost certainly me!) please let me know ...
> thanks,
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]