[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problems building from CVS on FreeBSD

From: Daniel O'Connor
Subject: Re: [Discuss-gnuradio] Problems building from CVS on FreeBSD
Date: Tue, 4 Jan 2005 18:29:27 +1030
User-agent: KMail/1.7.1

On Tue, 4 Jan 2005 09:55, Tom Huppi wrote:
> > Daniel, I haven't been a BSD user for many years, but it strikes me as
> > odd that the aclocal that's being referred to in your make output is
> > down under X11R6...
> Hi Daniel,
> I did get through the configure process and well into the build
> process.  I ran into some issues related to what you are seeing,
> but none quite so severe.  You night try setting PATH similarly to
> what I happen to have:
> /sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/us
> and see if some of them go away.

My path has those things in it (except your home directory of course :)

> I've been carefull to use the ports collection to install all of
> my auto(x) tools in default since if I can figure out how to make
> them work that way, it will be more usefull to others (and myself
> for that matter.)  I executed the autotools as you have.  It is
> odd to me that your aclocal installation looks in
> /usr/X11R6/share/aclocal.  I have a modest collection of stuff
> there, probably from some minor X11 app I built through the ports

Well.. wxPython installs there for example, so it's not suprising it looks 

> infrastructure at some point.  The more robust collection is in
> /usr/local/share/aclocal.  I suspect that for whatever reason,
> when you specify 'aclocal19', you are finding a neutered version
> installed for the purpose of building some (broken) X11 app from
> ports.  That is why I recommend looking at your PATH.  Note that
> when you 'build' the auto(x) tools, they are 'compiled' to know
> where to look for their supporting files via --prefix, so if you
> execute the 'wrong' one, it can make a difference.

I tried to find versions closest to what was reported to work on this list, 
but the ones I used were the closest I could find.

Daniel O'Connor software and network engineer
for Genesis Software - http://www.gsoft.com.au
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C

Attachment: pgpVcF_di9gIn.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]