[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] scopesink.py crashes, Mac OS X, wxPython

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] scopesink.py crashes, Mac OS X, wxPython
Date: Fri, 14 Jan 2005 15:40:56 -0800
User-agent: Mutt/1.5.6i

On Fri, Jan 14, 2005 at 01:36:05PM -0800, Jonathan Jacky wrote:
> I have built gnuradio-core, gnuradio-examples, and gr-wxgui on Mac OS X.
> I also installed wxPython (, numarray (1.1.1) and Numeric (23.7).
> When I try "pythonw scopesink" it does display the scope with a sinewave
> trace on it.  But then the scope window freezes; it is unresponsive to
> input (even to close it).  The wxPython stdout/stderr window displays
> a traceback (shown below).
> After the gnuradio-core installation, "make check" reported one error:
>  .... gr_vmcircbuf_sysv_shm_factory: Failed
> All the other checks passed.

That isn't really an error.  I'll fix the message.

> scopesink.py has "import Numeric".  I also tried running with
> numarray by replacing this with "import numarray as Numeric". 
> It failed in exactly the same way.
> I also tried the other demos in wxgui.  waterfallsink.py displays 
> a blank window and freezes --- the stdout/stderr window does not
> appear.  fftsink also draws a blank window and freezes.  There is a
> stdout/stderr window below it, but I can't read it because it is
> covered by the blank window, which can't be moved.
> Any suggestions?
> - Jon Jacky

Sorry, I've got no clue.

How about the wxpython demos from http://www.wxpython.org/download.php

[Note to any Apple folks listening: an equipment grant of a PowerBook
 would be put to good use... ]


reply via email to

[Prev in Thread] Current Thread [Next in Thread]