[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Segmentation fault

From: mgray
Subject: Re: [Discuss-gnuradio] Segmentation fault
Date: Tue, 5 Apr 2005 22:12:37 -0700 (MST)

I built gcc-3.4.3 from the ground up and then built all the support 
applications and GNU radio using gcc 3.4.3.  I still get the same core 
dump if I use the --enable-sse command line argument. 

If I REMOVE this setting and build it, everything works fine.

I do have the core files and can do any other tests as desired.

Building all that stuff takes a while, even on a fast machine.  I need to 
get back to the DOS days and make a RAM drive. :)

On Tue, 5 Apr 2005, Eric Blossom wrote:

> On Mon, Apr 04, 2005 at 09:19:14PM -0700, address@hidden wrote:
> > I built FFTW with 
> > 
> > ./configure --prefix=$HOME/gr --enable-single --enable-shared
> > 
> > and wxPython-src-
> > 
> > under Red Hat FC 3 with all updates (using up2date) and it now runs all 
> > the gnuradio-examples
> > 
> > It looks like there is some sort of problem in libfftw3f with the SSE
> > instructions.  I'm not sure why.  I thought the SSE would run on a stock
> > P4 processor.
> I suspect that FC3 has patched a bug into gcc.
> I run with --enable-sse all the time and don't see a problem.  
> FWIW, I don't use FC2 and FC3 because I find them excessively buggy.
> Eric

reply via email to

[Prev in Thread] Current Thread [Next in Thread]