[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] _gnuradio_swig_python import error on Mac OS X

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] _gnuradio_swig_python import error on Mac OS X
Date: Sun, 24 Apr 2005 12:00:51 -0700
User-agent: Mutt/1.5.6i

On Wed, Apr 20, 2005 at 10:22:03AM -0700, Jonathan Jacky wrote:
> >ImportError: No module named _gnuradio_swig_python
> I fixed it.
> On Mac OS X, the build creates _gnuradio_swig_python.dylib.  But
> python's import statement will only import files ending in .py, .pyc,
> and .so (I found this by trying "python -vv").

> I just put made a symbolic link _gnuradio_swig_python.so and pointed
> it at _gnuradio_swig_python.dylib in the same directory.  That worked!


> So now I've got an (apparently) working gnuradio-core-2.5 on Mac OS X.
> I'll post a writeup of everything I had to do soon, after I've
> cleaned up some loose ends.
> Can someone explain where in the build (which Makefile or
> whatever is relevant) is _gnuradio_swig_python built?  Perhaps I can
> figure out where and how to change some switch so it builds an .so not
> a .dylib on Mac OS X.  I feel a little guilty about just faking it
> with a link ...

It's built in gnuradio-core/src/lib/swig.  See Makefile.am in that

> Jon Jacky
> PS.  There is a patch for Python that gets it to import .dylib files
> also, but it's a source patch, so I didn't bother.
>  http://mail.python.org/pipermail/patches/2004-June/014925.html
> https://sourceforge.net/tracker/?func=detail&atid=305470&aid=641685&group_id=5470
> PPS. I didn't have this problem when I built gnuradio 2.3 in January.
> Sure enough, I find I have a _gnuradio_swig_python.so there.  The only
> thing I have changed since then besides gnuradio itself is SWIG, I
> moved from 1.3.22 to 1.3.24 as advised.  I've also installed a few OS
> and security updates but I wouldn't think they changed the toolchain.

Perhaps you've got a different version of libtool?  That's the package
that we use to create the shared library.  IIRC there are two packages
called libtool on OS/X.   One is the autotool tool, the other does
something different.  


reply via email to

[Prev in Thread] Current Thread [Next in Thread]