[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] usrper fails in usb_claim_interface

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] usrper fails in usb_claim_interface
Date: Wed, 27 Apr 2005 19:55:12 -0700
User-agent: Mutt/1.5.6i

On Wed, Apr 27, 2005 at 09:36:26PM -0400, James Cooley wrote:
> I am now seeing something like this one crop up, very annoying.
> Basically, I'm running in RX mode for a while. I stop running. I may 
> unplug usrp, plug it in. Then:

When you unplug, are you unplugging from power and/or the usb?

> ====================
> usrp: found usrp rev2
> usrp_open_interface:usb_claim_interface: failed interface 2
> could not claim interface 2: No such file or directory
> usrp_basic_rx: can't open rx interface
> Traceback (most recent call last):
> <snip python traceback stuff>
> ====================
> I've tried many things to try to work around it. Sometimes I've tried to 
> reboot, but that doesn't *always* work. I should say, I'm running a few 
> things off of USB... an external hard drive, the usrp, and a DB9 serial 
> adapter thing.
> Can it be solved in the same way, rmmod usbtest? Or is there something 
> else at work?
> -jamie

This doesn't sound like a usbtest problem.  That only shows up with
USRP motherboards that haven't had their EEPROM initialized.

Is there anything in the kernel logs?

What kernel are you running?

Haven't seen this before.  I'll see if I can reproduce it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]