[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] usrper fails in usb_claim_interface

From: James Cooley
Subject: Re: [Discuss-gnuradio] usrper fails in usb_claim_interface
Date: Wed, 27 Apr 2005 23:19:37 -0400
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050317)

When you unplug, are you unplugging from power and/or the usb?
Hard to say, I believe I have done both. However, I haven't been able to piece together an exact set of circumstances that lead to this problem. Sometimes it happens, sometimes not is about the best that I can say for now. ;) I've tried many combinations of yanking out, etc. to try to reproduce, and also so far cannot. Most of the time, it works beautifully, but when it gets into this funk, there's not much I can do.

I do notice in the logs if I unplug and replug the USB, the kernel does seem to properly note the device being removed, then re-added and no problems are associated with it.

How does the USRP know to load its firmware? I notice the first time I run, there's a bit of a delay as stuff happens behind the scenes. It may be the case that if it has already been loaded (or thinks it has), this situation happens. Is there a way to force a re-load or whatever else is going on?

This is a debian testing distro with a 2.6.10 kernel on top.

Is there anything in the kernel logs?

What kernel are you running?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]