[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] "Failed to set initial frequency" and SDCC 2.5.0

From: Lee Patton
Subject: Re: [Discuss-gnuradio] "Failed to set initial frequency" and SDCC 2.5.0
Date: Thu, 27 Oct 2005 20:45:17 -0400

Eric -

I have the DBSRX board (800-2400 MHz) in the RXA slot.  The board seems
to be recognized.  Here is what is printed out. 

address@hidden usrp]# ./usrp_oscope.py -f 2000M
RX d'board A: DBS Rx
RX d'board B: <none>
glibc detected *** double free or corruption: 0x09aa9808 ***
Abort (core dumped)

(Note: I get a core dump if I close the GUI window with File->Exit or
just x-off the window. However, I don't get the core dump message if I
CTRL-C in the shell.)

I tried entering the frequency in the text box and pressing enter, but I
get the message "DDC: is invalid. Enter a float with optional scale
suffix. E.g., 100.1M" 

I'm not sure if the frequency I'm supposed to enter is the carrier I
want to receive, the vco freq, or the DDC output freq. So, I tried the
above w/ 100.1M, and got the same result.

I don't know if this is relevant, but I installed the usrp CVS code.
After the install, I downloaded usrp-0.8.tar.gz from the gr downloads
page, and did a 

# cp usrb-0.8/fpga/rbf/usrp_fpga_rev2.rbf

Is this correct?

 - Lee

On Thu, 2005-10-27 at 16:34 -0700, Eric Blossom wrote:
> On Thu, Oct 27, 2005 at 07:14:38PM -0400, Lee Patton wrote:
> > Hi all -
> > 
> > I seem to have the baseline packages, gnuradio, and usrp code installed
> > okay. The example files "usrp_oscope.py" and "usrp_fft.py" run and
> > display active data on the line. However, I cannot set the frequency.
> > The GUI displays the message "Failed to set initial frequency."
> Which daughterboard are you using?
> Usually "Failed to set initial frequency" is because either the
> default or the command line argument is out of the range that the
> daughterboard can successfully tune.  (The daughterboard's set_freq
> method returned False.)
> If you've got more than one Rx daughterboard, are you specifying which
> one you want to receive on using the -R {a,b} command line option?
> Have you tried changing the frequency by entering a number in the text
> field and pressing enter?  To set 104.5 megahertz, enter "104.5M"
> (without the quotes).  104.5m will try to set to 104.5 millihertz.
> 104.5 wills to 104.5 hertz...
> On the command line, the same SI standard suffixes work.  M is
> probably the one you want:  ... -f 104.5M
> > I originally installed SDCC 2.5.0, but after reading the USRP README, I
> > installed SDCC 2.4.0. This did not fix the problem.  SDCC 2.4.0 won't
> > compile *completely* under gcc 3.4 (which is why I used 2.5.0 in the
> > first place), but it does (apparently) generate all the files required
> > by gnuradio.  I say this because the example files run. I just can't set
> > the frequency.
> > 
> > My questions are:
> > 
> > 1) Any idea how to fix the problem causing the "Failed to set init..."
> > message?
> See above.
> > 2) Can SDCC 2.5.0 be used, or is 2.4.0 an absolute must?
> I haven't tested with SDCC 2.5.0.  
> 2.4.0 had some compiler bugs that I had to diagnose and work around.
> I'm not sure if 2.5.0 is better or just different.  2.4.0 is known to
> compile our code correctly.
> Looks like SDCC 2.4.0 fails to compile the AVR simulator under gcc
> 3.4, but that doesn't matter to us, since we aren't using the
> AVR microcontroller, or any simulator for that matter.
> Eric

reply via email to

[Prev in Thread] Current Thread [Next in Thread]