[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] failed to find usrp[0]

From: Pacho V
Subject: Re: [Discuss-gnuradio] failed to find usrp[0]
Date: Wed, 25 Jan 2006 03:56:25 +0100
User-agent: KMail/1.8.2

hi LRK, Eric, and other USRP users:

thank you for your answer. unfortunately i was not able to solve my problem :(

On Friday 20 January 2006 22.14, you wrote:
> On Fri, Jan 20, 2006 at 04:56:37PM +0100, Pacho V wrote:
> > i'm a new user of the USRP and have encountered the following problem.
> > when trying to run 'test_usrp_standard_tx' i get the following messages:
> >
> >         usrp: failed to find usrp[0]
> >         die: lt-test_usrp_standard_tx: usrp_standard_tx::make
> >
> > i'm using a quite recent version of mandriva, i installed python and
> > wxpython using the package manager available from the distribution. all
> > the other needed packages (gnuradio-core, etc) were installed in one
> > subdirectory of my home directory. to do that i used
> >
> >         ./configure --prefix=$HOME/gnu-radio --enable-maintainer-mode
> >
> > the installation went more or less alright. when doing 'make check ' i
> > got the message that Numeric couldn't be loaded. i decided to ignore this
> > message since typing 'import Numeric' inside python worked fine.
> >
> > the usb connexion seems to work smoothly:
> >
> >         Jan 20 04:29:41 localhost kernel: usb 3-2: new high speed USB
> > device using
> > ehci_hcd and address 73
> >
> > can anyone suggest how to identify the problem? thank you very much for
> > your answers.
> usrp[0] not found is usually a permission problem. I have system running
> Mandrake 10.1 and remember having to find where the device actually is
> and either change permission or add my user to /etc/group.

could you give more details on this? i'm configured as follows:
(i'm using mandriva 2006)

uid=500(renato) gid=500(renato) groups=4(adm),10(wheel),43(usb),500(renato)

moreover, i noticed the directory /proc/bus/usb/ is empty and it has the 
following permissions:

dr-xr-xr-x  2 root root 0 Jan 25 03:51 usb/

another thing is that usbview (that i installed) doesn't work because it tries 
to read the file '/proc/bus/usb/devices' which does not exist!

> The '--enable-maintainer-mode' is not supposed to be required now.

i decided to cvs-rebuild everything from scratch and install everything in the 
default locations (as root via 'su -m'). this time i omitted 

> The 'make check' problems are various but usually some environment
> variable is set wrong or you have an old installed library that is
> found by the scripts before the new one.

this time 'make check' did not produce any errors. however, i still got the 
same problem, i.e. failed to find usrp[0]. someone suggested me to use 
'strace' to see what's going on with 'test_usrp_standard_tx'. the result was 
the following (follow link):


there are many 'No such file or directory' messages. 
i also tried a python example (usrp_oscope.py) and obtained the same error. 
here is the log:


the following env. variable is set:


> Good luck.    (not sent to the list)

i'm getting nuts... does someone know what's wrong?
thank you very much for your answers.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]